iPod touch wifi connetions failure

Discussion in 'iPod touch' started by martinonline, Nov 17, 2009.

  1. martinonline macrumors newbie

    Joined:
    Oct 3, 2008
    Location:
    Denmark
    #1
    Hi everyone.

    I have just bought an new Ipod Touch 32GB.
    My router is a Linksys WRT54GL with the orginal firmware on it. It runs WPA2-personal and TKIP+AES with a relatively long password (I think it's above 50 characters)

    All our computers connection without any failure to the wireless network, but it fails with my iPod touch :confused:.
    I have tried entering the password a couple of time, and checked that is was right, but is still won't connect.

    (I have now tried chainge the WPA2 til WPA-personal, but it doesn't work either)

    Do you have any suggestion?

    // Martin.
     
  2. RabbidAssassin macrumors member

    RabbidAssassin

    Joined:
    Nov 8, 2009
    Location:
    Sac, CA
    #2
    I have the same router and same iTouch as you. The first iTouch I got did the same thing and a few days later none of my apps would open. I called Apple Support and they told me it sounds like a back board in the touch. I took it back to Target and got another one.

    A few weeks later when I went to the Apple Store to pick up my new iMac they said the same thing about the WiFi. :apple: But this is just want happened to me.
     

Share This Page