iPod Touch Wifi Problem

Discussion in 'iPod touch' started by AndrewVenner, Feb 19, 2008.

  1. AndrewVenner macrumors member

    Jan 13, 2008
    Okay, so my iPod used to have wifi working perfectly, but now there's a grey icon that says "No Wi-Fi". If anyone has a solution to this problem, it would be greatly appreciated. Thank you.
  2. dustboy macrumors member

    Nov 30, 2006
    we'd need some more specifics..are you in range of a known working network? Have you tried it with different networks? Is there a password needed?
  3. AndrewVenner thread starter macrumors member

    Jan 13, 2008
    I'm in my house right next to my router. No password required. Normally 2-3 bars. But I don't even have the option to change my settings, or connect to any networks because it just has a gray icon that says "No Wifi", when I can usually at least try and join a network.
  4. mbguerreiro macrumors newbie

    Feb 24, 2008
    ipod Touch Wi-Fi problem

    I have the very same problem. My ipod touch 16GB shows a "No Wi-Fi" message and does not allow me to enter the configuration page anymore. I have a domestic wi-fi system, and my laptops work just perfectly, and so did the ipod until a couple of weeks ago.

    I have reset, updated firmware to 1.1.3, sinc'd again and nothing changes. Do you think the wi-fi damaged somehow?
  5. youradhere4222 macrumors 6502

    Dec 16, 2007
    I'm having the exact same problem.

    I'm having the problem, also....

    I can't even touch it. I'm within a router I've connected to before (locked), my laptop has a connection, etc. Running 1.3.1 with update....
  6. patioman macrumors newbie

    Mar 20, 2005
    I had this problem at one point, too. No networks visible even though I KNEW my home network and my work network were working. Fixed it by restarting the iPod.
  7. mbguerreiro macrumors newbie

    Feb 24, 2008
    I decided to take my ipod to service yesterday here in Brazil. Apple people tested it and reset it. It still did not work. They told me it is a rare internal defect, so they are going to replace my ipod in 30 days.

    I hope the new one does not bring this defect.
  8. mightyfifi macrumors newbie

    Jul 27, 2008
    i have a similar problem. i just got my 8gig ipod touch in the mail 2 days ago. i tried to connect to my router and got connected. however none of the internet capabilities are working, it just keeps saying it can't connect to the server. it is a password protected network however i have made sure the password is correct. all the internet things do work on unprotected networks though. im not sure if this is the route of the problem.

  9. mbguerreiro macrumors newbie

    Feb 24, 2008

    I found a solution to the "no wifi problem", and unfortunately the solution is to take the iPod to an Apple store and have it replaced by a new one. Apple told me this is a "rare" defect, and it is not possible to fix it at home...
  10. mightyfifi macrumors newbie

    Jul 27, 2008
    I figured out a solution to my problem. You have to connect to a websites ip directly without using the sites "nickname." The problem was with the iTouch's transfer with DNS. Somehow when I bypassed the DNS part once I no longer needed to again.

    If you have the same problem try connecting to google through it's ip with u can search a find via google on ur desktop/laptop.

Share This Page