iPod touch will not charge

Discussion in 'iPod touch' started by effybroome, Dec 9, 2013.

  1. effybroome macrumors newbie

    Joined:
    Dec 9, 2013
    #1
    My iPod touch 4th generation will not charge. I got it brand new in July. It's completely dead but when I plug it in it says that it's charging and nothing changes in the bar.
     
  2. mpantone macrumors 6502

    Joined:
    Mar 20, 2009
    #2
    Sounds like a candidate for a factory warranty replacement. Bring it to the Genius Bar at the local Apple Store.

    Good luck.
     
  3. Aspasia macrumors 65816

    Joined:
    Jun 9, 2011
    Location:
    Halfway between the Equator and North Pole
    #3
    Have you tried using a different cable or power adapter, just to make sure one of those isn't the issue?
     
  4. Espeonia macrumors member

    Espeonia

    Joined:
    Sep 10, 2013
    #4
    -Why a 4th gen?
    -My 4th gen did this a while back last year; the status bar wouldn't update, but it was charging. A restore solved the problem for me.
     
  5. WonderKid938 macrumors 6502a

    WonderKid938

    Joined:
    Apr 14, 2013
    #5
    I had a very similar problem recently and I replaced the power cord and it worked
     

Share This Page