iPod Touch Will Only Play Sounds On A Dock

Discussion in 'iPod touch' started by melissapete24, Jul 2, 2013.

  1. melissapete24 macrumors member


    Feb 12, 2013
    I have a 4th generation (?) iPod Touch, 32 GB, not the newest iPod touch, but the second newest. It is completely up to date, and it has worked perfectly ever since my mother gave it to me when she upgraded to an iPhone 5. This morning, I plugged it into my MacBook (late 2009-model white unibody), which is also entirely up to date with newest OS and all software updates. It synced, and I waited until it told me it was finished, clicked eject, and unplugged it. I got into my car to go to work, plugged the auxiliary cable in like I always do, and hit play. It played two songs just fine, but a minute into a third song, it stopped producing sound. I looked down at my iPod, and there was no slider for the volume. I tried using the volume buttons, and they didn't do anything, either. I unplugged the auxiliary cable, but still no sound, volume slider, or volume button usage. I rebooted the iPod: still nothing. I got to work and plugged my iPod into my iHome, which uses a docking system rather than an auxiliary cable, and it works perfectly. I pulled the iPod off the dock, and it's once again giving me sound. However, I'm afraid this will happen again. My iPod didn't start acting up like this until after I plugged it in to my Mac to sync it. Anyone else have this problem or know a solution? Quite frankly, I am stumped.
  2. glutenenvy macrumors regular


    Sep 6, 2011
    The description sounds software/media/settings related.
    Check if the same problems happen while using corded headphones.
    Shut off bluetooth as you are using an aux cable. You could be connecting to a bluetooth device it was paired with earlier.
    Try removing any external case you have on your device.

    Still have problems after this?

    The first thing I'd have to ask is was it unlocked while you were trying to change the volume and is it jailbroken?

    Another thing to look at is if you have a corrupted media file that you synched onto your device. If what appears to be a software problem happens while playing the same media, you can safely suspect a media file.

    Lots of problems are resolved by recovering and doing a complete ios reinstall. I'd do that before looking for a bad media file.
  3. melissapete24 thread starter macrumors member


    Feb 12, 2013
    Yes, the problem was the same with headphones. I don't have Bluetooth turned on on it, as I have nothing for it to connect to via Bluetooth, so I figured it was probably a waste of battery to leave Bluetooth on. I don't have a case for my iPod.

    Yes, it was unlocked when I was trying to adjust the volume. But I tried locking it and then double-clicking the home button to bring up the volume slider and forward and back buttons, etc. Everything but the volume slider showed up.

    The iPod isn't jailbroken.

    No, the songs haven't changed at all. No new ones. I just wanted to update my apps, basically, sync the apps I bought on my iPod to my computer. And it wouldn't play ANY song, I tried probably a dozen or so from all over my music library.

    I'm not going to mess with the iOS right now, as it is working properly again ever since I docked it on my iHome. Because, knowing my luck, I'll jinx myself somehow. Ahaha.

    But, honestly, I don't know why it did it. I was worried I'd have to invest in a new iPod, and I'm dead broke right now, but I need my portable tunes!

    But, as I said, ever since docking it on my iHome, it has been working perfectly again, as if nothing ever happened. So, we shall see, I guess.


Share This Page