iPod Touch won't charge?

Discussion in 'iPod touch' started by kflsj10101, Mar 14, 2011.

  1. kflsj10101 Guest

    Joined:
    Feb 24, 2011
    #1
    My iPod was working fine the other day but then it just died. So I'm thinking that "Ya it's normal for an iPod Touch to die". So when I got home i plugged in to my computer from the cable I was given by apple. It shows the Battery but was red and a lighting thing was on the bottom. So I let it charge for a night and it was still the same. So then I thought it was wet so I left in a rice bag for 2 days. But before that there wasn't and water in the screen. Today I tried to charge it but it was still the red battery with the lighting bolt below it. Does anyone know how to fix this? Am I screwed? I haven't even had my iPod Touch for a year so I would send it in but my iPod is Jailbroken. It's currently in the rice bag just to be safe. My iPod Touch is a 3rd Generation 64 GB. Thank You!
     
  2. ihavamacbookpro macrumors newbie

    Joined:
    Mar 19, 2011
    #2
    Ive had this same problem. I would really appreciate it if someone could figure this out.
    My ipod Touch is 32 gb 3rd gen.
     
  3. tgdbowler macrumors newbie

    tgdbowler

    Joined:
    Aug 12, 2010
    #3
    I've started experiencing a similiar issue as you have discribed. The cable itself doesn't fully connect to all the pins in my iPod Touch (2G) and I have to wiggle the cable to get the full connection. Your case may be different, but mine is with the cable that came with the iPod Touch. Hope this helps.
     
  4. iApples macrumors 65816

    iApples

    Joined:
    Mar 24, 2011
    #4
    This does happen to mine also. I plug the iPod Touch in and it shows the fully charged icon in the top right corner. Then when I unplug it, the battery is still in red. This happens pretty often actually. Normally what I do is just unplug it and replug it in. That normally fixes the issue. Seems like a lot of people are having this problem though.
     

Share This Page