ipod touch won't connect to wifi

Discussion in 'iPod' started by grosslyclever, Jul 20, 2009.

  1. grosslyclever macrumors member

    Jun 25, 2009

    I have an ipod touch first generation and it won't connect to my time capsule (TC has wifi built in). When I type in my password on my ipod and press join, a message pops up saying: "Unable to join network" "network name"

    I tried reseting my network setting but the same message pops up. I tried connection with a password and without one but still no luck. I went to a friends house to try his network and it worked there.

    My Time Capsule Radio Mode is 802.11n only (2.4 GHz).

    Anyone have any ideas on how to fix this problem? Did anyone else have this problem?

    Thanks in advance,
    - GrosslyClever
  2. SG1-1 macrumors member

    Apr 30, 2009


    The iPod touch wifi radio is "G" band only , You need to set your Router to Output both wireless "G" and "N". And you should Be Fine.

    Maybe the 3rd Gen iPod will have "N" band also, But for now, 1st & 2nd Gen iPod's are only able to function with "G" band Wireless.:apple::)

    Good Luck.

Share This Page