Ipod touch won't restore! Freezing problems whilest restoreing!

Discussion in 'iPod touch' started by Kunamoto, May 5, 2010.

  1. Kunamoto macrumors newbie

    Joined:
    May 5, 2010
    #1
    Hi, lately my ipod touch has been acting weird so i desided to restore it, i didn't connect it to my computer to restore it i used the reset all in the general app. When it finshed (took 2hours) i tried turning it on but nothing worked, it was bricked on the apple logo, so i set it in dfu mode then connected it to itunes. I then restored it, but then it got stuck on waiting for ipod, i left it for half and hour to the point where i had no choice but to unplug it. When i tried restoring it again it went to the apple logo with the loading bar but then the loading logo (the spiral thing) froze and this happens every time i try! I've tride leaving it for an hour till it said that it timed out! I really need help. Btw, it was jail broken on 3.1.1, please help and thank you!
     
  2. jrdnkasparek macrumors newbie

    Joined:
    Jul 5, 2009
    #2
    i had this same problem a while ago
    when i used a different computer it worked like a charm.
    you might want to try this first
     
  3. Kunamoto thread starter macrumors newbie

    Joined:
    May 5, 2010
  4. mi986 macrumors member

    Joined:
    Jul 29, 2008
    Location:
    Victoria, Australia
    #4
    I had this problem a few weeks ago.

    Make sure you are using genuine firmware downloaded from iTunes and that you have the latest version of iTunes. Put it into DFU mode and then click 'Restore' and let it download a copy of the 3.1.3 fw.

    Just leave it, it can take H-O-U-R-S sometimes.
     

Share This Page