iPod touch won't restore, it's been three weeks and I'm going insane!

Discussion in 'iPod touch' started by The Pimp King, Dec 5, 2007.

  1. The Pimp King macrumors newbie

    Joined:
    Nov 25, 2007
    #1
    3 weeks ago, I got an iPod touch. The iPod touch would not connect to iTunes (though was detected by the computer) and the message I got was "iPhone could not connect because of an unknown error". Great.

    I tried and tried again until eventually, I decided to put it in restore mode and the computer after trying over 20 times, it would not restore due to "an unknown" error. My mother's friend's friend got it to sync on his computer, though that was a bit useless because I need it to sync with my computer. Convinced that my iPod was broke (also had lots of dead pixels) I sent it back to the store. I got a new one and the exact same thing happened! So now I am stuck with an iPod that will not restore!

    I have tried everything I could think of. I have uninstalled itunes and quicktime countless times, went to countless message boards and just done everything I can think of.

    Any advice? I am seriously going crazy and its really annoying me.

    Specs:

    Computer:

    Windows XP (legal)
    512MB RAM
    2.0 Ghz processor
    iTunes (7.5)
    Quicktime

    iPod:

    8GB
     
  2. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #2
    That sucks dude. Since it worked on your friend's computer, maybe there's something wrong with your USB port. The only other thing I can suggest is re-installing Windows XP although you won't find much help on the Windows side here at "MacRumors" because this is pretty much exclusively a Mac website but, good luck to you and I'm sorry to hear about your iPod touch issues.
     
  3. hecks macrumors regular

    Joined:
    Oct 27, 2007
    #3
  4. gkarris macrumors 604

    gkarris

    Joined:
    Dec 31, 2004
    Location:
    "No escape from Reality..."
    #4
    Try uninstalling the USB in Hardware Setup, then hit refresh so the system reinstalls it. Reboot and try again...
     
  5. n0th1n9 macrumors newbie

    Joined:
    Nov 12, 2007
    #5
    search for n0th1n9's post

    Pimp, do a search for posts on my name. There is a thread I had responded to with a sync issue similar to yours with a small how to fix. Now to get to the registry editor you need to open 'Run' and type 'regedit' and then navigate your way through the registry files that are on the other thread.
     
  6. The Pimp King thread starter macrumors newbie

    Joined:
    Nov 25, 2007
    #6
    Didn't work...:c Thanks for the great help though!
     
  7. Cosmo modo macrumors member

    Joined:
    Dec 25, 2005
    #7
    I had the same problem.....

    Go into setings on your iPod, and into General > Reset
    and choose Erase All Content and Settings

    Then the iPod needs to reboot and then connect again to your computer......

    Now you will need to copy all data again onto the iPod, but at least you can use it again.....
     
  8. Cosmo modo macrumors member

    Joined:
    Dec 25, 2005

Share This Page