iPod Touch won't update to Firmware 2.0

Discussion in 'iPod touch' started by caseyw, Dec 26, 2008.

  1. caseyw macrumors newbie

    Joined:
    Sep 13, 2008
    #1
    My brother and me had both received iPod Touches for Xmas, both with $50 gift cards.

    I updated mine to firmware 2.0 through my computer, my brother synced his with my parents' computer which already has 2 iPhones synced with it as well. I updated mine to the 2.0 firmware easily on my own iMac, but when my brother tries to update to the 2.0 software for $9.95, it asks him if he's sure, then shows a software agreement, then simply reports that he cannot buy this because he is not authorized. I tried deauthorizing and then reauthorizing the computer with his account, but nothing changed.

    Can anyone help? My brother really wants the upgrade to play his favorite games.

    PS, both are the 2nd generation iPod Touches
     
  2. dopey220 macrumors 6502

    dopey220

    Joined:
    Jul 19, 2006
    #2
    No one can. There are already like 4 threads about it.
     
  3. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #3
    Old iPod touches? The new ones come with at least 2.1.1 out of the box, the one we got for my Mum had 2.2 pre-installed.
     
  4. dopey220 macrumors 6502

    dopey220

    Joined:
    Jul 19, 2006
    #4
    I'm assuming the OP is talking about Refurbs. I got a refurb 1st gen 8GB, and it came with 1.1.5. I'm having the same problem upgrading to 2.2; I would guess that Apple's having server issues. I wouldn't sweat it; it'll probably be fixed within a day or two.
     
  5. Walt DI macrumors member

    Joined:
    Dec 4, 2008
  6. r4dical macrumors newbie

    Joined:
    Oct 11, 2008
    #6
    If they're second generation, they should come with at least 2.0.
     
  7. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #7
    I believe this is an issue with the iTunes servers being overwhelmed with traffic from Christmas...

    Everything I have seen said, to wait, and try again later...
     
  8. mackmgg macrumors 65816

    mackmgg

    Joined:
    Nov 2, 2007
    #8
    f 2.0 they come with 2.1.1 or 2.2 which means YOU just wasted 10 bucks to buy something because you didnt read carefully to the description
     
  9. dopey220 macrumors 6502

    dopey220

    Joined:
    Jul 19, 2006
    #9
    BUMP

    I successfully updated to 2.2 last night. Looks like they've fixed it.

    (in case anyone having the same problem hasn't checked yet.)
     

Share This Page