iPod Video 5.5G (30GB) Upgrading to CF-->SD setup help!

Discussion in 'iPod' started by Johnny365, Jan 22, 2016.

  1. Johnny365 macrumors regular

    Johnny365

    Joined:
    Nov 30, 2015
    #1
    So I am trying to upgrade to a CF ZIF board and chose this one:

    http://amzn.to/1Sax83l

    I have it all installed and used this CF adapter:

    http://amzn.to/1Sax9o5

    I have a new battery installed as well. Everything's connected, but it keeps booting to the Sad iPod icon with the URL for apple support. I know it's not my iPod as the 30GB hard drive still works and loads to the main menu (and plays music!). The ZIF ribbon is also still good as I switched back to the hard drive and it detected fine.

    I don't know what to do. I tried Menu + Center (restarts iPod), I tried Play + Center (disk mode).

    Disk Mode I can only get to trigger once every 50+ times as it simply cycles through to the URL screen mentioned above.

    Diagnostic menu, I can't figure out how to access. Connecting it to a Windows machine, no detection in My Computer or within iTunes (again, is detected when I have the 30GB swapped back in).

    The only thing I don't understand is whether I have the CF Zif board installed correctly. I believe the CF card/board should be facing the screen? None of the pins are bent. I am using a 64GB MicroSD to SD adapter for the CF card.

    I also tried a regular 16GB SD card, and same URL error message.

    Help! :p Thanks
     
  2. rgarjr macrumors 603

    rgarjr

    Joined:
    Apr 2, 2009
    Location:
    Southern Cal
    #2
    Most likely its not mating good with the ZIF ribbon. Try CF to SD adapter facing towards the chrome backplate.
     
  3. Johnny365 thread starter macrumors regular

    Johnny365

    Joined:
    Nov 30, 2015
    #3
    I tried that. I get the same URL screen that cycles on and then off. I even tried formatting in Fat32 (windows) and mac journeled (mac). Is there a way to clone the files from the 30gb to the SD card so that it boots?
     
  4. Johnny365, Jan 23, 2016
    Last edited: Jan 23, 2016

    Johnny365 thread starter macrumors regular

    Johnny365

    Joined:
    Nov 30, 2015
    #4
    So I cloned a copy of the 30GB HDD to the SD Card, and inserted it back in the iPod. Still same screen. I also tried flipping the CF Zif board around and nothing.
    --- Post Merged, Jan 23, 2016 ---
    More trouble-shooting:

    The board is indeed supposed to be facing the screen. I inserted a 32GB CF card and was able to enter disk mode.

    The easiest way to enter Disk Mode is when the iPod is powered off, just press and hold Center + Play and keep holding until the check mark shows on screen.

    iTunes also showed that the iPod encountered a problem, but needed to be reformatted. It failed obviously, because the 32GB CF card is dead (won't format no matter what--I already knew this).

    It narrows the problem down further, because now I know the board is installed correctly and is working. Now I just have to determine if the Digigear CF-->SD adapter is faulty, or the use of a MicroSD to SD adapter, or the 64GB MicroSD itself!
     
  5. Johnny365 thread starter macrumors regular

    Johnny365

    Joined:
    Nov 30, 2015
    #5
    Okay. Next update!

    I recently upgraded my iPod Mini 2nd Gen from 4GB to 64GB. The path was 64GB SD to CF adapter.

    I removed the 64GB SD Card from there.

    Instead of having a 64GB Micro SD to full SD to CF, I just put the 64GB SD to CF adapter and it is now working. Not completely sure if it was the MicroSD causing problems, the type of 64GB MicroSD (samsung sdxc type), but ehh I'm just glad it's working and detecting the full capacity.
     
  6. Johnny365, Jan 23, 2016
    Last edited: Jan 24, 2016

    Johnny365 thread starter macrumors regular

    Johnny365

    Joined:
    Nov 30, 2015
    #6
    Final comments: While the MicroSD card works everywhere else, I reckon there were compatibility issues with the SD-->CF adapter (Digigear brand). It further leads me to believe that the Digigear adapter could be faulty. I forgot to mention that the one from my iPod Mini 2nd Gen, I switched into the iPod Video 5.5G and didn't think of trying the adapter I specifically bought for this upgrade.

    I will test it in the iPod Mini 2nd Gen sometime in the near future. I just want to make sure I get the same exact 64GB SD card I used in the iPod Video 5.5G (again, as that one worked in the iPod Mini).

    Update: I tested the Digigear CF adapter I used in the iPod Mini mod I did and it wouldn't work in the iPod Video 5.5G--it gave me a sad iPod icon with the URL again. Don't know why, as they are both adapters that accept SD cards. It worked fine in the iPod Mini.

    Also, the case wouldn't close completely with the setup I used, so I had to cut the CF adapter out to expose the bare PCB which made it much thinner. I just used electrical tape to cover the circuits on both sides and now both halves of the iPod case close perfectly!

    Thanks for reading everyone! Hope this helps at least one person!
     
  7. Johnny365 thread starter macrumors regular

    Johnny365

    Joined:
    Nov 30, 2015
    #7
    Here's after installing a new white faceplate from China. Looks and works great! The stock black one was cracked in a few places and the tabs were not the best.

    [​IMG]
     
  8. kamikazekaze macrumors newbie

    Joined:
    Feb 16, 2016
    #8
    Hello !

    I Have bought a qumox 128 gb sdhc card, a komputerbay 64gb 266 cf card and the iflash adapter.
    My Ipod 5.5g 30gb is from ebay. The hdd was broken.

    I cant get it to work no matter what i try.
    If I insert the cf or sd card, and let the ipod charge it gets in a loop and shows me the sad ipod or low battery.
    Putting it into disk mode and connecting to the computer, it wont show up in diskutility or itunes.
    After about 10 seconds the please do not disconnect screen disappears and the ipod restarts.
    Going to systeminformation -> Usb -> the ipod will show up, so it is recognized by my computer somehow.

    Doing the self test (pressing select and back), the ipod passes ram test and seems to be fine.
    Doing the hdd smart data test = no result.
    HDD specs = shows me some strange letters and that the hdd capacity is 97gb (eventhough i built a 64gb cf or a 128gb sd card in it, still shows the same

    Got 4 hdd flex cables, that I tested. And still no different result
    Tried formating the Cards fat 32 and mac journalled but the device still behaves the same.

    When I start the device the apple logo appears and stays for a few seconds before the sad ipod logo appears.

    Thanks for help.
     
  9. Johnny365 thread starter macrumors regular

    Johnny365

    Joined:
    Nov 30, 2015
    #9
    Did you replace the battery with a new one? Make sure the HDD ribbon cable is installed the correct way. The exposed metal has to line up to the prongs where they clip to the board.

    I know some memory cards are finicky and won't work with the iPod 5.5G.

    I used this one and it works: http://amzn.to/1SveXHi
     
  10. kamikazekaze macrumors newbie

    Joined:
    Feb 16, 2016
    #10
    So I got a ipod classic 4g 40gb.
    This needed another adapter (ide to cf).
    Put in the same 128gb qumox sd card with Tarkans sd to cf adapter.
    Worked :)).
    Immediatly recognized by itunes.

    Only difficulty was having a firewire cable.
    The ipod 4g non color needs more power I guess 12 V to power up after restoring the firmware.
     

Share This Page