iPod Video 5th Generation: No Response

Discussion in 'iPod' started by MaxMike, Oct 17, 2010.

  1. MaxMike macrumors 6502

    Dec 6, 2009
    I was about to do a restore on my iPod 5th generation 80GB to have it set up with my Mac mini. When I went to turn it on, nothing happened. It did flash a few times just white with about 30 seconds in between, but now it won't do a thing. I thought it was just a dead battery, so I plugged it in: No response. I have it plugged in now to see if it is just the battery being completely depleted. I tried holding Menu+Enter with nothing happening. Hard drive doesn't make noise and screen stays off. Is my beloved first iPod dead? :(
  2. FixYouriTunes macrumors member


    Oct 16, 2010
    San Francisco
    It certainly sounds like it. I have a problem with my Classic iPod where I have a big red X on the screen. It keeps going back to the red X when I turn it on but while in that mode I hear the internal hard drive clicking.

    For yours I would just leave it off for a while and maybe come back to it. I've had iPods since 2003 starting with the 30GB white iPod. I believe it was the 2nd generation and it died a couple of times but I physically changed the battery and it worked a while longer (although not as good as it did prior) and continued using it until it completely died. Which was last year!

Share This Page