Ipod Won't Charge (New Battery/Logic Board)

Discussion in 'iPod' started by Fail Cat, Nov 7, 2008.

  1. Fail Cat macrumors newbie

    Nov 7, 2008
    Hey everyone, and thanks for reading,

    About 2 weeks ago I replaced the logic board on my iPod after the factory one died on me. Everything worked fine, although my battery had been losing its longevity for a while. It still took charges fine though.

    I woke up one morning to find that my iPod, despite displaying the charging symbol, had not charged my iPod (5.5 Gen video) at all. Over the next few days I tried everything I could (ejecting it before charging, changing DVI cables, reseting the computer, using a different computer, resetting the iPod). No matter what, and no matter how long it charged for the battery would still display in the red.

    I bought a new battery. Replaced it. It worked. I charged it for the reccomended time, and it still read the same battery level. After a day or so of this the iPod is now reading "Please Wait Very Low Battery". Only, whatever was wrong with it before is preventing it from charging out of this mode. So now I can't do anything. The battery is brand new. The software is up to date. Can anybody think of something I might be missing???

    Also, I'm looking for a way to backup my iPod to a hard disk but it's next to impossible to find any information on it. It's like Apple just doesn't want you to do it. I can find plenty of info on how to use your iPod to backup your hard disk, but not vice versa. I just don't want to have to lose my entire iPod hard drive when something like... well... THIS happens.

    It's really frustrating to do all this work on my iPod, and then be frozen out of it. It's honestly really unfair.

    Any help would be extremely appreciated.

Share This Page