.ipsw file does not work.

Discussion in 'Jailbreaks and iOS Hacks' started by hieuky, Nov 15, 2008.

  1. hieuky macrumors member

    Joined:
    Nov 15, 2008
    #1
    Hello!

    I have a problem with downloading an .ipsw file for some weird reasons. Been downloading that same bundle for so many times from different websites. I have a Mac and a version of 1.1.4 iPhone and am waiting to have the awareness of the steps to upgrade it to 2.1 and be able to hack it with PwnageTool first, but then... the .ipsw file won't even show up in the right format. :eek: Instead, it's shown as a regular folder with some files in it and I tried to add the ".ipsw" extension in the end to that folder and tried using PwnageTool, yet it was notified as invalid bundle. :mad:

    So, what can I do to be able to have the actual .ipsw file without my weird computer converting it into a folder?

    Thanks.
     
  2. dZp macrumors 6502a

    dZp

    Joined:
    Mar 29, 2006
    #2
    I expect you're using Safari to download your file. If so, disable the "Open safe files after downloading" option in Safari's Preferences. Or just look in your trash for the .ipsw file.

    The .ipsw file is just like a .zip archive, and OS X will extract the archive automatically with that Safari option turned on.
     
  3. hieuky thread starter macrumors member

    Joined:
    Nov 15, 2008
    #3
    Hii, thanks for your reply!

    :)

    Yah, I was using Safari and uhmm, didn't read the instructions on some other website. It said that it is recommended to download that .ipsw file in FireFox, then I did, then it worked! :eek:

    Howeverrrrrrr...

    Yes, another problem. Oh, mang.

    It keeps blacking out after a couple of minutes when clicking the upgrade button on iTunes over and over again. Stating that my computer has to be restarted; please press the power button for few seconds and eh, something like that. Happens so often ever since I plug in my iPhone to the computer. Even the USB flash memory.

    Is there any other way? Thanks so much, again.
     
  4. hieuky thread starter macrumors member

    Joined:
    Nov 15, 2008

Share This Page