iRealQuickSMS & iBlacklist, popup notification help please?

Discussion in 'Jailbreaks and iOS Hacks' started by NSK123, Mar 17, 2009.

  1. NSK123 macrumors regular

    NSK123

    Joined:
    Mar 29, 2008
    #1
    Ok I just installed iRealQuickSMS which is really good, but my problem is that I don't want the Apple pop-up notification to show whenever I recieve either a call or sms, so I have disabled these with iBlacklist.

    but the problem is.. That whenever I recieve an sms the iBlacklist app blocks the quickReply pop-up so I can't reply to the sms, I have to open the sms app instead :(

    Is there any solution for this problem? The main reason I have popup notifications disabled with iBlacklist is because I have statusnotifier installed so I just get the Icons up on the statusbar.
     
  2. mokeiko macrumors 6502

    Joined:
    Jul 19, 2007
    #2
    Irealsms advance settings:

    Make sure the first two settings are 'on' (I actually have all 5 'on').

    Irealsms UI settings:

    Make sure the show SMS icon is 'on'.

    It took me some time to get everything figured out using iBlacklist, irealsms, and statusnotifier working together but it does the job. The I only thing is that irealsms will use it's SMS icon instead of the statusnotifier when allowing calls/sms are enabled in iblacklist. Iblacklist will use it's icons, including badge count, when the blocked calls/SMS are enabled.

    It's a little confusing having everything set up. Good luck.

    Btw, I do not use winterboard at all (I do not like the slight lag) so if you are using a lockscreen theme, the SMS icon from statusnotifier may not work properly defaulting to the irealsms SMS icon.

    mokeiko
     
  3. NSK123 thread starter macrumors regular

    NSK123

    Joined:
    Mar 29, 2008
    #3
    Well I dont have blacklists or anything enabled, the only thing I have is that I have disabled the Popup notifications for Call/SMS, I dont use the Ireal SMS app but BiteSMS. I only have IrealQUICKsms installed because it works better than the one from bitesms.

    Do you think you could maybe post a few snapshots of your Irealquicksms settings? And how did you stop iBlacklist from blocking the quickReply popup?
     
  4. mokeiko macrumors 6502

    Joined:
    Jul 19, 2007
    #4
    Go to iBlacklist extras settings, turn off sms privacy.

    Be sure to respring or restart your iPhone to make sure the settings stick.

    I apologize for not reading your post thoroughly, I thought you were using irealsms (the full app). My advice may not work in your situation.

    mokeiko
     
  5. NSK123 thread starter macrumors regular

    NSK123

    Joined:
    Mar 29, 2008
    #5
    hmm well disabling the sms popup notifications will fix the problem but I will still get an sms popup on the lockscreen as this wont be blocked anymore,

    Anyways I dont think theres a fix for it, either iblacklist or ireal needs to do something about it.
     
  6. mokeiko macrumors 6502

    Joined:
    Jul 19, 2007
    #6
    IrealQuicksms should have a setting to turn off the quick reply popup on the lockscreen, irealsms has that option.

    mokeiko
     
  7. NSK123 thread starter macrumors regular

    NSK123

    Joined:
    Mar 29, 2008
    #7
    hehe sorry dude, I think I'm explaining it wrong, disabling the iBlacklist SMS popup notification will cause the Iphone to show the standard Apple SMS popup along with the QuickReply windows, Both on the springboard and on the lockscreen.

    Disabling the iBlacklist sms nitification will block the apple sms popup AND the quickreply window

    While having iblacklist popup disabled I'll only get a badge on the sms icon which requires me to open the sms app to read the message ... thus, beating the purpose of the quickreply.

    It seems as if messing with the settings I can fix the problem on the springboard But I still get a standard Apple SMS popup on the lockscreen.

    And I have homescreen 2.0 installed that has its own, recieved sms/call/mms notification which I'm using.


    unless there's an app that will only block sms popup's on the lockscreen then I dont think theres a solution. :(
     
  8. mokeiko macrumors 6502

    Joined:
    Jul 19, 2007
    #8
    We should be able to find a way to make it work as our apps are not completely that different, it's the way the settings are being set

    mokeiko
     
  9. Next Tuesday macrumors 6502a

    Next Tuesday

    Joined:
    Sep 14, 2006
    Location:
    Orlando,FL
    #9
    You dont need blacklist. Just turn on compatibility in the Irealquicksms settings. Then the normal text or call bubble wont show up, just the ireal sms one.
     
  10. Malcontent macrumors newbie

    Joined:
    Aug 5, 2010
    #10
    Same problem.

    I have irealquicksms... and I don't wany ANY popups to show while the phone is locked, but I want quick reply pop-ups to show once I unlock the phone. I got comfortable with this on android and believe it's more secure, yet still allows me to reply quickly.
     
  11. michaelmols macrumors newbie

    Joined:
    Aug 6, 2010
    #11


    Still need blacklist to block certain callers though
     

Share This Page