Irritating issues with websites. Possibly Safari 5, maybe Airport?

Discussion in 'PowerPC Macs' started by Xandros, Nov 5, 2013.

  1. Xandros macrumors regular

    Joined:
    Sep 19, 2010
    #1
    So I have this PowerBook G4 15" (1.6GHz DLSD "Hi Res" with Airport Extreme, running 10.5.8). She's served me well. But recently, I've really started to notice something extremely annoying with it. This problem has been there for a long time but as the computer is now my main computer after the untimely death of my PC earlier in the year I've done pretty much all my web surfing on this machine alone, and this problem pertains to web surfing and good grief has it become glaringly obvious.

    Right so, sometimes I'll try to load a website and Safari will "get stuck". No two ways about it, it will start to load a site but appear not to get beyond the DNS lookup (as if I have no Internet connection, which I do), it'll sit there with no activity for a good 30 odd seconds if not longer until it eventually times out and craps out a "server not found" error. However this just isn't true; the server is there and working fine because I can access it on my mobile phone at the exact same time (using the same wireless network). Not only that but it can happen to sites I've been surfing at the time, I may go to load a page on the site and it'll do this nonsence completely (it seems) at random. It doesn't do it all the time. I can surf sometimes for hours with no issue, other times I can'[t go five minutes without it doing it to me. As is sod's law too it's usually when I'm trying to access something important that it does it to me (when time is of the essence also seems to be a catalyst though this all might just be a big fat coincidence it's still bloody irritating).

    It gets weirder though. I figured out quite early on that I can "unstick" Safari by opening a new tab and loading a different website! It doesn't always work but when it does all other "stuck" websites suddenly begin to load as if there was never a problem. E.g. say I've got three tabs all with this brick wall problem happening, if I open a fourth tab and load facebook and it works then all of a sudden all three of the other tabs will load the site like they should have done in the first place.

    If facebook doesn't work to unstick it, usually some other random site I type in will.

    I had for a very long time suspected my wireless router, a billion 7800N, but the other day the wifi card in the router burnt out (apparently a common issue for them), so I've have to revert back to my old 3com router and the problem still persists.

    Since I can load sites that are apparently non existent on the Mac perfectly fine at the same time on my mobile (running Android) while connected to the same wifi, that leads me to suspect the Mac is the harborer of the fault here and nothing else. What I don't know is if it's actually Safari or if it's instead the Airport software, or the card. Or perhaps something else?

    Any insights? Anything I can perhaps do to try and track down the problem?
     
  2. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #2
    This is why I hate Safari. It's always done this to me. You could try resetting Safari, but I don't know if that'll do the trick and it might wipe out your data.

    Some others here might have some better suggestions. I don't use Safari for a number of reasons, but this one being chief among them.

    I know it does not solve your problem, but my only suggestion would be switching browsers. If you're ok with Firefox you should know that there is a developer who makes a version of Firefox for the PowerPC Mac. It's called TenFourFox and you can find it at tenfourfox.com. It works on OS X 10.4 and 10.5 and the latest stable version is 17. That's equivalent to Firefox 17.

    If you care to try the beta you can find the downloads for it at tenfourfox.blogspot.com. Cameron Kaiser, the developer just released T4Fx 24, which is equivalent to Firefox 24 and is the browser I am typing this into right now.

    T4Fx is maintained and gets routing updates and is a secure browser if that's a concern for you. Note that any addon you can run in regular Firefox you can use in TenFourFox! So, all those addons over at addons.mozilla.com are wide open to you.
     
  3. davidg4781 macrumors 68000

    Joined:
    Oct 28, 2006
    Location:
    Alice, TX
    #3
    Resetting Safari will erase all your Safari data.

    I'd try another browser first. If that doesn't work, and you're alright with resetting Safari try that.

    Also try using Ethernet.

    Maybe also delete your network from Network Settings and try reading it. Maybe something got goofed up.

    Last resort do a backup and reinstall OS X. Hate to go that route but if there's anything goofed up in your system that should sort that out.
     
  4. Xandros thread starter macrumors regular

    Joined:
    Sep 19, 2010
    #4
    Well I'm no stranger to resetting safari but that doesn't work, unless it does but the underlying problem still exists so the problem just comes back after a while making it an unnoticeable fix.

    Oddly enough my renewed interest in getting this fixed made me do some indepth searching, and I came up with an actual offical Apple article about these sorts of issues and a setting in safari called "DNS Prefetching" and how to turn it off. So far with it off I must say I haven't noticed the issue reoccur... Early days yet though.

    If this truly is the culprit, I noticed in the article apple tries to blame these half-opened, or non loaded web sites on of all things my router not working properly with dns prefetching. Well since I've had two routers over the years and this annoyance has been apparent throughout both their lifetimes, and the fact they're both very different models and makes, I'm going to hazard a guess, Apple, that either no router on the market except maybe a select few work with dns prefetching or the problem isn't with the router but your shoddy workmanship in making dns prefetching work properly on this end...
     
  5. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #5
    Do you have a link? If I can slay this particular dragon my use of Safari might increase a bit.

    Interesting though how it's only Safari that has this DNS prefetch problem. Other webkit-based browsers don't seem to have it.
     
  6. Xandros thread starter macrumors regular

    Joined:
    Sep 19, 2010
    #6
    Ah yes, sorry I should have linked to it.

    http://support.apple.com/kb/TS3408

    Still trying it out, but due to some major broadband and router issues lately I haven't been able to get a definitive answer to if it actually worked or not yet. Hope it does.
     
  7. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #7
    Well I actually found the link after I wrote my reply. Tried it and things have improved, but are no where near what I get with TenFourFox or any other browser.

    Sorry to say, but Safari still sucks eggs for me.
     
  8. Xandros thread starter macrumors regular

    Joined:
    Sep 19, 2010
    #8
    Indeed, though I'll put up with it for now. As and when I get a new PC or rebuild the old one, that'll become my main net browsing system again, as such I can't really be bothered to load a different browser on the system.
     
  9. micahgartman macrumors member

    micahgartman

    Joined:
    Feb 22, 2005
    Location:
    Houston, TX, USA
    #9
    I had the same problem with my PowerBook 1.33GHz. I disabled the DNS pre-fetching, which helped a little bit. Then I started using WebKit for Leopard. It works MUCH better than plain ol' Safari.

    There's a new version out—537.69. I've been using it on the PowerBook and my MDD and it's fantastic!

    http://code.google.com/p/leopard-webkit/
     
  10. Xandros thread starter macrumors regular

    Joined:
    Sep 19, 2010
    #10
    Interesting. Thanks for that, didn't know anyone was still keeping the webkit framework up to date. I have briefly used it but... I can't honestly say I noticed anything change. Safari is still acting like a complete twonk. But then again I suppose it certainly can't hurt to have it even if performance doesn't improve with Safari (I suspect my issues with Safari are just the fact it's just a crap browser). Of course I'm still suffering from a combined slow Interweb and old/crap WiFi network so I still can't rule out current problems being to do with them.

    I've got DNS prefetching back on again now too after I reset Safari all back to defaults the other day when it stopped working completely for some reason. I can't be bothered to turn it off again; I don't think it'll make any difference even if I do.

    Some further notes about things I've been doing that people may find interesting; given that I only use this Mac to do basic web surfing I don't really need it for things like Flash video. Deciding that, at version 10.1, Flash is vastly outdated on PowerPC, I looked into removing it completely. Turns out Adobe have a Mac installer/uninstaller application that does this nicely.

    While I was at it, I used their Shockwave uninstaller too. I suspect most people probably forget about the Shockwave plugin but that's also outdated and crap on PowerPC Macs. After these two things were gone I went into Safari's preferences under Security and turned off the Plug-ins and Java setting (which I normally do have disabled but because I reset Safari back to default they needed setting again).

    ------------------------------------------------

    Here's an interesting thing to note too; Java. I hate Java. And the version on Leopard, 5 SE, is so old, outdated and bug/security hole ridden it's not funny. I don't use Java for anything, not even some websites (or so I thought). The interesting thing here is if in security settings, Java is unchecked, then it shouldn't be using Java. Right? Or am I reading into that setting incorrectly?

    I can't be can I? I don't know... Seems logical if you ask me. Take for example, my currently dead Windows PC. It ran Windows 7 and FireFox twenty-something when it was alive and kickin' but I did not have Java installed on the system. Microsoft stopped doing their own Java Envirment years ago, and left it to users to decide if they wanted to install Sun, now Oracle's Java software. Again since even on that system I don't use it for anything at all, I didn't have it installed on that system.

    Therefore logic suggests that FireFox can't use Java because it isn't there to use. So when I wa smerily using websites like Facebook.com, you wouldn't expect them not to work properly. And sure enough, they did work properly.

    Soooo... Why is it, they don't work properly on Safari, when Java is disabled in the Java Preferences app?! II tell no word of a lie... Having decided Java was useless to me, and the fact i had it (supposedly) turned off in Safari anyway, I went into Java Preferences and unchecked Java 5 (1.4 was already unchecked).

    I'm unsure if you can actually remove Java from the system completely. But turning it off seemed feasible enough for the time being without any hassle of deleting files.

    But that's when I found, while using Facebook, some things don't work anymore! I don't know if anyone's familiar with Farcebook but if you are you know that in your news feed, people's stories show up and if you hover your mouse cursor around the top right corner of a status there's a drop down menu, which allows you to hide posts and articles and change certain settings etc. There's also the links you click in the comments sections of statuses to expand them and show more comments...

    Well, with Java turned off on this system, none of these links and buttons work! It can't just be a coincidence, seeing as if I quit Safari, turn on java 5 in the preferences, then start Safari and load Facebook again, all of a sudden those links and buttons work as expected. And if I quit Safari, turn off Java 5 again, reopen Safari and load Facebook again, none of those buttons work...

    If I were to abbreviate three words and post it as a way of expressing how I feel about this, it would be:

    W.T.F.

    How the hell does that figure? I've got Java disabled in Safari's security prefs and yet it was still using Java "just because"? More to the point, Java doesn't exist on my WIndows machine and yet FireFox is able to use Facebook fine and dandy. What, so Safari requires Java? Can't do! The only thing I can think of is certain things like this FireFox is able to emulate Java on a basic level?

    I mean... I... I... If I was a robot my head would have exploded by now.:eek:
     

Share This Page