Irritating mic problems

Discussion in 'MacBook Pro' started by thomdalladay, Apr 9, 2010.

  1. thomdalladay macrumors newbie

    Joined:
    Dec 30, 2009
    #1
    Hey,

    I'm having some severe problems with my mic under BootCamp. I have a MacBook Pro 2.2 (2.33GHz/2Gb/160Gb). I currently have Windows 7 installed via BootCamp.

    My problem is if I use my mic, it causes feedback. If I have my external mic plugged in, it doesn't register anything for Line In and I still get feedback (presumably it's still using the internal mic). If I plug in my external headphones, I still get feedback via the mic!

    Any idea what's going on and is there a solution? Everywhere I look talks about Cirrus Audio for the 2009 model, that or topics on no sound from the mic.
     
  2. Patrick J macrumors 65816

    Patrick J

    Joined:
    Mar 12, 2009
    Location:
    Oporto, Portugal
    #2
    If the symptoms don't occur on the Mac side, it is a driver problem. Apple support for Windows, driver-wise, could be better. I don't, however, know how to fix your problem: have you tried Windows XP? XP and, to some extend, Vista, have better driver support.
     
  3. thomdalladay thread starter macrumors newbie

    Joined:
    Dec 30, 2009
    #3
    I'm using the Vista drivers - since this laptop doesn't support the latest BootCamp, I have the previous version with Vista drivers.
     
  4. Ice Dragon macrumors 6502a

    Ice Dragon

    Joined:
    Jun 16, 2009
    #4
    My cousin has a MacBook and wasn't satisfied with her built in mic. I gave her my Gigaware USB mic which worked perfect for me in Windows Vista and XP and works great for her in OS X.
     

Share This Page