Is a 30+second wait to browse a shared folder normal?!

Discussion in 'Mac OS X Server, Xserve, and Networking' started by meady100, Oct 9, 2011.

  1. meady100 macrumors member

    Joined:
    Oct 9, 2011
    #1
    I have two new iMacs both running Lion, both on the same wired Gigabit ethernet. Blazing transfer speeds, but the initial shared folder connection takes anything from 30 seconds to a minute. Can anyone tell me if this is normal? I was expecting a response time similar to a local drive (ie, near instantaneous). Thanks if anyone can advise! Settings: as out of box, have simply made a new folder on secondary drive (computer contains SSD and HD as BTO), shared it in network settings with all permissions set to read/write. Most vexing!

    Steve
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    Not normal, but I'm afraid that I can't offer any suggestions.
     
  3. Lagmonster macrumors 6502

    Joined:
    Sep 22, 2007
    #3
    I am getting the exact same wait. Not so from my Linux box. Grrrr
     
  4. crazzyeddie macrumors 68030

    crazzyeddie

    Joined:
    Dec 7, 2002
    Location:
    Florida, USA
    #4
    I've found this behavior is linked to Kerberos authentication. If you change AFP to use "normal" connections, they are instant. However, "normal" really means plain text, so you definitely don't want to use that...

    What the solution is to making Kerberos fast (again), I'm not sure.
     
  5. crazzyeddie macrumors 68030

    crazzyeddie

    Joined:
    Dec 7, 2002
    Location:
    Florida, USA
    #5
    I think I have found the reason behind this. Kerberos authentication is auto-configured based on all the IP addresses your server has ever had. Therefore, if you configured your Mac with one IP initially, then changed it later, your clients will try to connect to both IPs... given that one is probably inactive, the clients wait for that request to time out before going with the real IP.

    I was able to resolve this problem using this page, among others:

    Link 1

    After removing the old addresses from my kerberos config using Workgroup Manager, I ran the following command which I think resolved my problem:

    sudo kerberosautoconfig -u
     
  6. meady100 thread starter macrumors member

    Joined:
    Oct 9, 2011
    #7
    This looks hopeful! Thanks for keeping the thread alive - I have been checking back everyday. Will try it out tonight after work and report back...
     
  7. meady100 thread starter macrumors member

    Joined:
    Oct 9, 2011
    #8
    Pretty much by chance I seem to have fixed the problem. After the OSX 10.7.2 update last night, I found that my 'back to Mac' feature in the control panel was complaining 'may be slow because NAT port mapping (NAT PMP) or universal Plug and Play is turned off on your router'. This struck me as a possible link to my original problem. I therefore updated the firmware on my router (which dated 2008, with the latest version 2011 - whoops!). Everything now seems to connect and work instantly. Hope this helps someone... Incidentally my router was a DLink 655.
     

Share This Page