Is an SMC reset advised after ML upgrade?

Discussion in 'OS X Mountain Lion (10.8)' started by Synergie, Jul 25, 2012.

  1. Synergie macrumors 6502a

    Joined:
    Jan 15, 2011
    Location:
    Halifax, Canada
    #1
    I have been reading that a few people on here were having issues with their fans running high speed etc after the upgrade. I responded in one post, but figured it deserved its own thread.

    1. Is an SMC reset necessary or advised after an OS X upgrade? I know it's advised with hardware upgrades... and it doesn't hurt the system in any way to do it... plus it's simple. Does the OS upgrade do anything or modify anything that could cause issues with the SMC?

    2. Would this possibly solve the fan issues since the fan speed is controlled by the SMC, and one indicator of SMC needing to be reset is that the fans start running high speeds for no valid reason... ?? There are a host of other issues that could indicate that an SMC reset is needed too, like display issues, sleep / wake issues etc.



    I am downloading ML as we speak... hoping to not have any issues but if I do, I'll try it and report back...
     
  2. SimonTheSoundMa macrumors 6502a

    Joined:
    Aug 6, 2006
    Location:
    Birmingham, UK
    #2
    No, not at all.

    Wont hurt to do it, but there is no reason unless you do get issues which is very very rare.
     
  3. rkaufmann87 macrumors 68000

    rkaufmann87

    Joined:
    Dec 17, 2009
    Location:
    Folsom, CA
    #3
    1. No however doing a Reset Disk Permissions in Disk Utility would be wise.

    2. There was no fan issue in any previous version of OS X, however your machine may need a SMC reset if it's having a problem. BTW as a general rule of thumb NEVER upgrade to solve a problem, it will only make your problem more difficult to troubleshoot and fix. Therefore if you are having fan issues, handle that before even thinking of upgrading to ML.
     
  4. Synergie thread starter macrumors 6502a

    Joined:
    Jan 15, 2011
    Location:
    Halifax, Canada
    #4
    It's not me thats having the issue... I read on several others posts on here that only after the ML upgrade, they started having problems where their fans were running high speed non stop for no reason, even after a reboot. I figured it might be worth a try since it's a simple thing to do and the SMC CAN affect the fans...
     

Share This Page