Is anyone else also unable to download and/or install High Sierra Beta from App Store?

Discussion in 'macOS High Sierra (10.13)' started by Erdbeertorte, Jul 22, 2017.

  1. Erdbeertorte macrumors demi-goddess

    Joined:
    May 20, 2015
    #1
    Hi,

    I did a clean install of El Capitan today on my 12" MacBook (2016) what had been unused for a while and later decide to give APFS another try because I just read somewhere that it is faster and also remembered it from Beta 1 on my MBP, what I can't use at the moment.

    High Sierra did not show up in my purchases, what might be normal but I am not sure. So I installed a freshly downloaded Developer Beta Access Utility again, the App Store launched and the High Sierra site showed up.

    The Download finished very fast and I wanted to create a bootable USB stick for a clean install, but Disk Maker X gave me an error. Then I saw the file was only maybe 24 MB instead of 4.9 GB.

    But the installation window came up before and I thought maybe it is downloading the rest when I click on install. So I just started the installer directly from my SSD and also got an error, that something is missing.

    Updating to Sierra didn't help and it was the same on my iMac which already is on Beta 3 but only has an HDD. APFS wasn't offered to me in the installation process back then. So I think it doesn't make any sense without an SSD.

    I tried several times to download it again and it always finished after the above mentioned 24 MB. Also I always had to run the Access Utility again and again to make it show up.

    I forgot it is Saturday and this happened shortly before the time when Apple releases new betas. So I checked several times if there is a new version. But of course there was nothing new on the weekend.

    Then I managed to download it on my iMac, but it was 5.2GB instead of 4.9GB and I got the same error after clicking on install.

    After that I tried it again with the Public Beta Access Utility on my MacBook again but the download did not even start anymore.

    Then back to the Developer Beta Access Utility and it seemed the download finished a few minutes after it showed only calculating. Now it says downloaded but there isn't anything in the Applications Folder.

    Also on my iMac where the larger than expected file is, there is still a white "almost finished download bar" beneath the Applications Folder in my Dock.

    This is everything very strange. Does anyone have the same problem? Should I see it in my purchases?

    Of course I rebooted both Macs and deactivated beta updates in between.

    Those are two totally different devices and three different OS versions. Clean Internet Recovery 10.11.6 + the latest updates and later 10.12.5 on my MB 2016. 10.11 DB3 on my iMac 2011.

    There wasn't any problem downloading and installing El Capitan and Sierra first one shortly before and the other one a while after I decided to upgrade to High Sierra to try it again.

    Sorry for the long text. I just wanted to point out that I tried almost everything to get a non faulty installer from the App Store.

    Maybe it's even working again after I finished writing here. But I won't try it again today. Too much hassle already. :(
     
  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    My MacBook Air does not even report there is sth called High Sierra, despite I set to receive beta software update.
    So you are not alone.
    I am using 10.12.5.
     
  3. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #3
    Sorry to disappoint you but APFS is not faster yet, I didn't see any speed improvements after installing HS, this might change though in later beta's.

    5.2 instead of 4.9 means nothing, you see that often on webpages and after downloading it it's bigger.
    Which error you got.

    'Burn' it onto a USB and install.
     
  4. Erdbeertorte thread starter macrumors demi-goddess

    Joined:
    May 20, 2015
    #4

    Hi,

    making a bootable USB was my plan and it finally worked with another 5.2GB download later. There seemed to be a problem on the server side of the App Store but only the High Sierra download, when I got the small file and a corrupted full file or even nothing but looked like it was already downloaded.

    Another problem was DiskMaker X what even states compatibility only for up to Sierra but it worked before. I chose a different tool that states the same and it worked for the not corrupted download I got later.

    The error I got when clicking on install directly on both of my Macs was "some additional components are missing/have to be downloaded" or something like that.

    Strangely I am on the public beta now what seems to have the same build number and don't get iTunes 12.7. I reinstalled the Developer Beta Access Utility before my last download and also after the clean install from USB, when I saw the 12.6.2 update, but it didn't help.
    On my iMac I got 12.7 together with the update from beta 2 and never saw the 12.6.2 update. But even on my iMac there was a link to the Feedback Assistant in Utilities + Dock and I got prompted to login. Before it was always hidden in /System/Library/CoreServices/Application and I was never able to choose the current macOS and iOS version to report something. I always use the bug report website anyway.

    Maybe both betas can't be distinguished by the App Store anymore as long as they have the same build number.

    You are correct about APFS but the speed improvements I mentioned was only meant for copying files on the same drive. Like putting something into a cloud folder to upload a "backup" or leaving files on the Desktop that even though they are also somewhere else on my Mac. Because those are not real copies with APFS, it's almost instant, even for real large files. But I assume you know this.
     
  5. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #5

    APFS will get faster, this is just a beta, I am sure most people which read this won't agree but I am pretty sure Apple does this on purpose, I have seen it before that it was slow but then in one of the later betas it instantly gets a boost.

    Installing and Updating used to be a breeze before when macOS was still OS X and a couple of versions back, back then I always manually installed an update, this way I could manually restart the way I want, now it takes too long to restart, a bit similar to Windows which I despise.
     

Share This Page