Is anyone having issues with MBA automatically connecting to home wi-fi?

ET iPhone Home

macrumors 68040
Original poster
Oct 5, 2011
3,745
492
Orange County, California USA
When I open the lid to my MBA and type in my password, it doesn't automatically connect to home wifi. I'd say, 30-40% of the time, I'd have to click on the wifi icon, search from the drop-down menu to select my wi-fi name.

I'm not sure if this is normal. Perhaps, it's not even the MBA and it could be the router. I don't know how to troubleshoot this. Thanks.
 

Mrbobb

macrumors 601
Aug 27, 2012
4,989
194
Go to your Preferred Networks pane, delete anything that you don't use everyday.
 

ET iPhone Home

macrumors 68040
Original poster
Oct 5, 2011
3,745
492
Orange County, California USA
Which router is it? Updated firmware or third party?
It's a Motorola from TWC.

----------

Go to your Preferred Networks pane, delete anything that you don't use everyday.
Thanks for this. Much appreciated. I noticed my home wi-fi was 3rd from the preferred list. So what I did is "DRAG NETWORKS IN THE ORDER PREFERRED". I did this first to see if my MBA connects to my home network first by dragging this on top. If the issues persist, then I'll troubleshoot by deleting the other two connections. I saw only 3 on the list.

I think, this might solve it. Thanks again.
 

ET iPhone Home

macrumors 68040
Original poster
Oct 5, 2011
3,745
492
Orange County, California USA
Go to your Preferred Networks pane, delete anything that you don't use everyday.
Quick update: Okay, so far, your solution has worked. I've signed-on three times today without issue connecting to wi-fi automatically by assigning my wi-fi right on top; even with the other wi-fi network present. Had to thank you once again.
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.