Is blackra1n a REAL jailbreak?

Discussion in 'Jailbreaks and iOS Hacks' started by Enigmafan420, Nov 4, 2009.

  1. Enigmafan420 macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #1
    When it first came out, I read some posts from users that were unable to install "real" jail broken apps (like OPENSSH). They would get weird errors like "this application requires a jailbroken phone" or something similar.

    My question is, is blackra1n a true, 100% jailbreak? Anyone find applications that are giving error messages similar to above?

    thanks!
     
  2. rKunda macrumors 65816

    rKunda

    Joined:
    Jul 14, 2008
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3
    This is a trick question ?

    It is a real JB and UL solution (RC3 version) Used it on my 3G last night, sold it today and buyer dropped in T-mobile sim and handed me a wad of cash.
     
  4. dan5.5 macrumors 6502

    Joined:
    Oct 26, 2008
    #4
    I jailbroke 3g and it works perfectley. Might redo my 3gs with blackra1n
     
  5. rodman109110 macrumors 6502

    Joined:
    Jun 7, 2007
    #5
    any benefits over pwnage tool aside from the unlock?
     
  6. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #6
    No trick question. When blackra1n RC1 came out, there were many people posting that there were several apps (and I can't remember which ones now) that literally told the user that they must jail-break their phone in order for the app to work.

    This was AFTER they were installed with Cydia.
     
  7. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #7
    I haven't heard of problems with SSH, but blackra1n does have problems with pc/mac programs that read iphone files through the USB connection. (Diskaid, ifunbox, etc) Those programs would give "this application requires a jailbroken phone" errors with iphones jailbroken with blackra1n. A fix for this was quickly made available through Cydia, so people who want to use those programs only have to install the patch through Cydia. Otherwise the blackra1n jailbreak is no different from pownage.
     
  8. bruinsrme macrumors 603

    bruinsrme

    Joined:
    Oct 26, 2008
    #8
    I have run diskaid without any issues with jb and blackra1n
     
  9. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #9
    This may have been what I was thinking though I thought it had something to do with SSH.

    Thank you for your help! :)
     
  10. dread macrumors 6502a

    Joined:
    Jun 16, 2009
    #10
    I jailbroke a week ago. Do I need to update to the rc3 version to unlock. If so do I just download the new version and run it like an update or do I need to restore and jailbreak again. Can I unlock on the RC2 version?
     
  11. jmyler macrumors newbie

    Joined:
    Feb 24, 2009
    #11
    Can you give some more information about the patch? Where can i find it in cydia. I want to be able to use i-funBox and i'm getting this error.
     
  12. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #12
    It's called something like "afc2add." Search for "add" and scan the ones that start with "a."
     
  13. billwynne macrumors newbie

    Joined:
    Jan 19, 2009
    #13
    BlackRa1n

    Works like a charm and has all the access I need.
     
  14. M87 macrumors 65816

    Joined:
    Jul 18, 2009
    #14
    OpenSSH works fine on my 3G jailbroken with blackra1n.
     
  15. Mac1212 macrumors member

    Joined:
    Mar 3, 2009

Share This Page