iPhone Is Bluetooth working with iOS 7?

Discussion in 'iOS 7' started by alanjfrancis, Jul 15, 2013.

  1. alanjfrancis macrumors newbie

    Joined:
    Nov 8, 2011
    Location:
    Stafford, UK
    #1
    Hi,
    I rarely use bluetooth and only use it to play music in my car, but since upgrading to iOS 7 neither my 4S nor 5 seem to connect to anything using bluetooth. Has anyone else noticed this?
     
  2. grockk macrumors 6502

    grockk

    Joined:
    Mar 16, 2006
    #2
    No. bluetooth works fine in both cars. Also pebble watch and headset work.

    Try re-pairing?
     
  3. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #3
    delete the old profile from your car and pair it again. I had to do that a few times even in iOS 6.
     
  4. 8a22a macrumors 6502a

    8a22a

    Joined:
    Mar 9, 2012
    Location:
    Yorkshire, UK
    #4
    My Pebble connects ok on iOS 7 although notifications are unreliable.
     
  5. fraggot macrumors 6502

    Joined:
    Jun 16, 2009
    Location:
    Cox's Creek, KY
    #5
    The only problem I have is when I connect it to my Auris it crashes my Spotify, but only when connected to that. I don't see how that happens but when I connect it to a bluetooth speaker I own, it works perfectly fine.
     
  6. alanjfrancis thread starter macrumors newbie

    Joined:
    Nov 8, 2011
    Location:
    Stafford, UK
    #6
    It's not just a matter of pairing them to my car (Toyota Prius). They are acting like they are undiscoverable. I can't even find them using my iMac or Macbook Pro.
     
  7. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #7
    It works at least for some.

    I have used it with my Pioneer, Sony headphones, and as bluetooth hotspot to my iPad.

    My photosync app cannot detect it is activated in order to beam photos to my iPad.

    So it works some.
     
  8. tiptopp macrumors regular

    tiptopp

    Joined:
    Aug 15, 2008
    Location:
    Norwich, UK
    #8
    Partially working

    I recently bought a pair of Jaybird Bluebuds, and have been loving them - great sound, good volume and easy to control the iPhone. However, possibly since Beta 3, the start/stop button doesn't work, which is frustrating, especially as I have a five-minute lock and complex password on my phone (work policy) and the lockscreen controls don't work either!

    I had been worrying about having to take them back, but as the same button works for last number redial and Siri, I guess it's just the Bluetooth stuff that's gone a bit awry. I remember similar Bluetooth issues last year with one particular beta...

    Roll on Beta 4!

    Tiptopp
     
  9. Skiking226 macrumors newbie

    Joined:
    Jun 10, 2010
    #9
    Same here, I have a Alpine, and iOS 7 bluetooth fails to work, trying to pair always says failed

    ----------

    Re-pairing, lol, I have 100 times, never works
     
  10. airbelchris macrumors regular

    Joined:
    Jun 27, 2013
    #10
    yes it works... but it is a pain in the butt..
     
  11. alanjfrancis thread starter macrumors newbie

    Joined:
    Nov 8, 2011
    Location:
    Stafford, UK
    #11
    Sorry, only just seen I've had replies to this. Bluetooth has been working fine for me since Beta6 :D
     
  12. ToeCutter macrumors newbie

    Joined:
    Apr 22, 2006
    #12
    I had my first long drive with iOS 7 GM yesterday and the Bluetooth disconnected without warning several times during my 3 hour drive. I was listening to Audible on my iPhone 5, which was rock solid with iOS 6 and all it's point releases (for A2DP, phone calls are a completely different story).

    I'm kinda frustrated that Apple can't provide decent Bluetooth functionality? While music profiles seem to work in iOS 6, phones calls would last about 20-30 min before becoming a cacophony of static. My Galaxy Note 2 (work phone) seems to function just fine? It certainly connects faster.

    I'm not sure if there have been any changes to the released build of iOS 7, but I'll update this evening to see if that resolves the Bluetooth issues.
     
  13. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #13
    I have a Prius and my 5 and girlfriends 4S connect just fine to the Bluetooth with iOS 7. Sometimes you have to repair. Tell iOS to forget the device, goto bluetooth settings on the car and it should make it discoverable. Then re-pair.
     
  14. recla macrumors newbie

    Joined:
    Sep 18, 2013
    #14
    My Bluetooth is working fine with ios7 except I cannot change the song on my pioneer deck like I previously could. Makes it highly annoying and defeats the wireless purpose. Any thoughts guys? Thanks!
     
  15. Strotter18 macrumors newbie

    Joined:
    Sep 19, 2013
    #15
    Same problem here . I have the pioneer fhx700bt . Can't skip on pandora or on your own music on the iPhone. With steering wheel controls But if you use the USB plug you can skip to the next song on pandora using the steering wheel controls. But you still can't skip on your own music. Been trying to call pioneer all day. First they were out to lunch then all I get is a busy signal now. iOS 7 iPhone 4S
     
  16. Strotter18 macrumors newbie

    Joined:
    Sep 19, 2013
    #16
    So got a hold of pioneer, pioneer said it was the metra axxess that's makes the controls for the steering wheel. I called them. They said it was apple. So I called apple. Apple said it was pioneer. Pass the buck. I think it has some thing to with sky net ... Maybe even Walmart or global warming. Maybe because there's a hole in the ozone layer.
     
  17. Nombreapellido macrumors newbie

    Joined:
    Sep 19, 2013
    #17
    Bluetooth Prius

    In my Prius it still works, but the steering wheel controls stopped working, so I can't play the next or previous song which is pretty annoying because I have to grab my phone and look for the next/previous button while driving! Apple needs to fix this, it was working fine with iOS 6.
     
  18. psg2000 macrumors member

    Joined:
    Feb 18, 2008
    Location:
    UK
    #18
    I have a Mercedes slk and cannot control with the steering wheel or central control.

    I also note that when I get into the car it used to automatically connect and play my music.

    Now I have to manually play it from the iPhone 4.

    So it does stream.

    It is very dangerous at the moment.
    Controlling through fingertip control is far safer than rummaging for the phone and skipping forward
     
  19. Nombreapellido macrumors newbie

    Joined:
    Sep 19, 2013
    #19
    Solved

    Solved the problem with my Prius. This is what I did:

    1. In your phone, Go to the settings, Bluetooth and click on the (i) of your car's Bluetooth. In my case it was CAR MULTIMEDIA. Then click on Forget this Device.
    2. Turn off Bluetooth in your phone so that it doesn't try to connect to the car's BT again
    3. Go to your car, turn it on and delete your phone from the BT settings of your car and reset all BT settings to Default
    4. In my Prius you have to delete the phone twice, because there's two BT connections, one for audio (multimedia/music) streaming and another one for phone Bluetooth (to talk on the phone). Make sure you delete both of them. It takes just a minute to do it, one is in the phone settings and the other in the audio settings.
    5. Turn off your car and wait for a minute or so (this might not be necessary but I did anyway)
    6. Turn your car on again.
    7. Turn BT back on in your phone
    8. Register your phone with your car's BT. The phone will ask you for the code (the default is 0000 or 1212).
    9. That's it, once they're paired again, everything went back to normal.

    Steering wheel controls are working again through Bluetooth, sound is great, and phone calling works again with no choppiness.

    Hope this helps.
     
  20. San Carlos macrumors newbie

    Joined:
    Sep 21, 2013
    #20
    I have same head unit and same problem.
     
  21. CTHarrryH macrumors 65816

    Joined:
    Jul 4, 2012
    #21
    Had to re-sync with my BMW after the upgrade but it seemed to work fine after that. Haven't driven that much so we'll see.
     
  22. Jimbo diddler macrumors newbie

    Joined:
    Sep 22, 2013
    #22
    Hi I've just updated to iOS 7 and is does play via Bluetooth but I can't skip through my music using the controls on steering wheel,I have a ford focus 13 reg,it worked before I updated software funny that
     
  23. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #23
    Disconnect and re-pair your phone.
     
  24. BOOmBoTz401 macrumors newbie

    Joined:
    Oct 21, 2012
    #24
    No issues here

    Alpine head unit
    Blue parrot head set
    Motorola hx550

    All connect great on ios7
     
  25. pauljohndavies macrumors newbie

    Joined:
    Sep 23, 2013
    #25
    Bluetooth - failure iOS7

    With iOS6, iPhone 5 and BMW were perfectly linked. Upgraded to iOS7, and eventually the screen to enter the pin came up and almost immediately disappeared. Tried endlessly - sometimes I even managed to enter one number before it said connection unsuccessful. Can't understand why upgrading should have required a new pin, and when it did, just immediately flashed off. I did remove the iPhone from the BMW end.
     

Share This Page