Is Firefox hogging my system

Discussion in 'Mac Apps and Mac App Store' started by Mac_i_Am, Mar 10, 2009.

  1. Mac_i_Am macrumors member

    Joined:
    Nov 22, 2004
    #1
    Hey guys + gals..

    My G4 Powerbook (powerpc) has been hiccuping lately.

    Basically, i'll be surfing or typing an email and every gesture takes 2-3 secs to complete. Even simple things like switching tabs or highlighting a few words are delayed.

    I'm no expert but i opened Activity Monitor to take a look and noticed Firefox running between 60 - 85%... and this is with it just sitting there. I attached a screen shot of this so you can see it.

    It seems to me that Firefox is causing this. But what can i do so it doesnt hog the system?

    BTW - I have OS X 10.4.11
    Firefox just upgraded itself to 3.0.7 and only had that plus Safari and Activity Monitor running.

    Thanks
     

    Attached Files:

  2. MikhailT macrumors 601

    Joined:
    Nov 12, 2007
    #2
    Disable all of your extensions and see if that fix the problem. It is possible one of them has a conflict that is hanging up firefox.
     
  3. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #3
    How big are the files in the Firefox profiles folder under Application support?

    If there are a couple really big ones sitting there, it could be a problem.

    I've killed urlclassifier and places, along with turning off IPv6.

    Now nothing but a really old copy of the bookmarks is over 1MB.

    Edit: before killing the places files, backing up the bookmarks is a good idea, since it contains the bookmarks and will rebuild it from the backups on restart.
     
  4. Mac_i_Am thread starter macrumors member

    Joined:
    Nov 22, 2004
    #4
    @ MikhailT -

    How do i go about disabling the extensions? :confused:


    @ Sun Baked -

    Assuming i went looking in the right area, there are 42 items under "Profiles"... (i attached a screen so let me know if thats right)

    Most files are well under 100kb and the largest by far is "urlclassifier2.sqlite" @ 5.5MB <<< Can i do something with this file?
     

    Attached Files:

  5. MikhailT macrumors 601

    Joined:
    Nov 12, 2007
    #5

    Tools> Addons
     
  6. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #6
    60-85% CPU usage will not cause that. only 95% above will be easily observable.

    The first question I would ask is:

    is your firefox slow? or the system is slow?

    you mentioned delay when you tried to change tabs, drag firefox windows.

    how about when you drag the finder window?

    if this is a system-wide slow down, it needs further investigation, because 60-85% CPU usage isn't going to cause it.

    If this is a firefox app slow down. try

    1. restart firefox
    2. clear cache, and restart firefox
    3. disable addons, restart firefox
    4. open firefox with a new profile.
     
  7. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #7
    urlclassifier2.sqlite

    Delete it, it will be recreated as a 4k file and won't grow bigger.

    ---

    Turn off IPv6, there are some posts around that will help you with this.

    Edit: if you have updated to the latest flash player, you might want to look to see if you can downgrade again. Flash problems with the latest player on PPCs (i think).
     
  8. Mac_i_Am thread starter macrumors member

    Joined:
    Nov 22, 2004
    #8
    Ok, so i'll try:
    - to disable the Extension
    - turn off IPv6
    - delete urlclassifier2.sqlite (though i read that it will rebuilt to its 'full' size)


    Its mostly firebox cos finder and other windows run relatively fast.
    I'll follow your steps as well but... i dont get #4 - how do i open with a new profile?


    Interestingly, firefox is running ~30% today and there's no hesitation at all.
     
  9. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #9
    When they switched to Firefox 3.0x they stopped using the urlclassifier2 database file, and the old bookmarks file.

    Almost looks like most of the stuff is in the new places database file, so expect this one to grow and hold all those autofill URL addresses.
     
  10. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #10
    You don't have enough RAM. The page out ideally should be 0.

    Have you tried a different browser. Flash heavy sites tend to require alot of processing power due to flash been poorly made.
     
  11. durija macrumors 6502

    Joined:
    Jan 16, 2008
    Location:
    Seattle
    #11
    Try another browser. I use Opera mostly. I find both it and Safari to be much faster than Firefox now.
     
  12. Mac_i_Am thread starter macrumors member

    Joined:
    Nov 22, 2004
    #12
    I prefer safari but its unstable on my computer and wants to close for no good reason. I really dont wanna try another browser, but i will def. stop using firefox if it keeps slowing things down.

    Hopefully the steps above will remedy all this. ::fingers crossed::


    @ consultant - Speaking of RAM, my lower slot doesnt work so instead of 2GB i can only go as high as 1GB.

    If you say page in should be 0, then i'm pretty much lost at 560,XXX arent i? :p
     
  13. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #13
    Doh on your RAM slot... Yeah you might be a little bit lost on that. Since you are having a lot of harddrive swaps, you might want to get a 7200rpm harddrive, but before that,


    You should NOT run 2 browsers at once with that amount of RAM.

    If you can do it, try it with a flash blocking plug in.
    Some allow you to whitelist certain sites or pages.

    You don't need virex. That's doing the Vshield thing which is taking up about 10% of your CPU. Uninstall Virex.

    Disk Utility: repair permissions, repair disk (repair disk requires you to boot up using another volume), download and reinstall safari
     
  14. Aronnax macrumors regular

    Joined:
    Feb 18, 2008
    #14
    Flash is the real problem on older G4 Macs.
    Try this Flashblock https://addons.mozilla.org/de/firefox/addon/433
    and everything will work very likely much better ;-)
     

Share This Page