Is it just me... Slight delay loading when browsing in Photo's

Discussion in 'macOS Sierra (10.12)' started by Z3man, Sep 26, 2016.

  1. Z3man macrumors 6502a

    Joined:
    Feb 19, 2012
    Location:
    UK
    #1
    Since the upgrade to macOS Sierra, when i am browsing my photo library in Photo's i seem to be getting a slight delay before the photo loads properly.

    Basically when i flick to the next photograph to view it, it appears immediately and looks ok but then about half a second later it all of a sudden brightens up and looks much better, it is as if the photo is taking about half a second to load properly.

    Does anyone else get this, i cant remember it happening before, if i switch to my old iPhoto library this doesn't happen.
     
  2. Z3man thread starter macrumors 6502a

    Joined:
    Feb 19, 2012
    Location:
    UK
    #2
    Can anyone using photos let me know if this happens to you please.

    I am using a 2015 MB.
     
  3. Rok73 macrumors 65816

    Rok73

    Joined:
    Apr 21, 2015
    Location:
    Planet Earth
    #3
    Is it possible that you have iCloud Photo Library activated in Photos/Preferences/iCloud and at the same time have chosen the option "Optimize Mac Storage"? That would explain the delay and changing of the quality because your Mac has to download photos from the cloud that aren't locally stored.
     
  4. Z3man thread starter macrumors 6502a

    Joined:
    Feb 19, 2012
    Location:
    UK
    #4
    Thanks for the suggestion, but i don't have iCloud Photo Library activated.

    Hopefully it might put itself right in the next Sierra update, which i think is coming soon.

    If that doesn't work i will look at alternatives or see if it is possible to go back to iPhoto.
     

Share This Page