Is it me or the Mac

Discussion in 'Mac Basics and Help' started by TomT321, Nov 9, 2009.

  1. TomT321 macrumors member

    Joined:
    Sep 14, 2009
    #1
    New to Macs and not at all sure what the problem is, but it appears that certain peripherals such as my Kodak Digital camera dock are not being recognized by the computer. It is plugged in to the USB port and there is power to the camera dock, and I downloaded the easyshare disc, however the camera won't download and I can not seem to find the photoprinter listed in any of the files. It has worked in the past, but I switched from Leopard to Snow Leopard and then back to leopard again and somewhere in all of that it seems to have lost some of the peripherals. The external hard drive also seems not to be recognized either, but not at all sure that it is not defective, have new one on order. Would appreciate any input.:confused:
     
  2. thejadedmonkey macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pa
    #2
    I'm not sure about the digital camera, except that it should theoretically work, even without the Kodak software.

    As to the hard drive, that doesn't have any excuse for not working. When you plug it in, does it spin up and show in finder? what happens?

    It sounds like your USB ports might not be working properly. Do other USB devices work if you plug them into that USB port? Have you tried other USB ports?
     
  3. rekhyt macrumors 65816

    Joined:
    Jun 20, 2008
    Location:
    Part of the old MR guard.
    #3
    Is it running as a NTFS format? (The memory card inside the camera.)
     

Share This Page