Is it my SSD or computer that's failing?

Discussion in 'Mac Basics and Help' started by swingerofbirch, Apr 14, 2013.

  1. swingerofbirch macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    I have a 2012 13" MBP with a Samsung 830 256 GB SSD.

    Just tonight, I tried taking a screenshot and got a message that I did not have permission to. I then tried saving open files and was told there was an error.

    Creating a new folder in the Finder caused a -50 error.

    I tried rebooting and got to the Apple logo with spinning wheel but it never went anywhere. No error messages.

    So, I restarted to Recovery Mode (Command-R). I opened Disk Utility from there, and it told me that there were errors with both the HD (listed as Samsung) and with Macintosh HD. The Macintosh HD error had something to do with the Journal. It could not be repaired.

    So, I booted to a cloned drive I had made with SuperDuper. It booted very slowly and beachballed and my internal HD did not show up.

    On a whim I decided to run Disk Utility from the cloned drive on the internal drive, and it again found errors but fixed them! I was so relieved (I do have a back-up clone but it's not terribly recent).

    I could see the internal Macintosh HD and all the files appear to be there. I tried restarting to the internal drive, but it just stays on the spinning wheel.

    I restarted back to the clone, and it still shows the internal drive. I verified it again, and it says the drive is OK.

    So, it seems like I should be able to back-up my data tomorrow (I want to wait till I get a new drive because I don't want to write over the data on my cloned drive in case it corrupts what I already have saved).

    But I'm wondering if once I back up, erase, and re-install my internal drive, assuming it works, should I trust it?

    I have a few theories:

    I do record a lot of video and use the drive pretty heavily. Could I have depleted the write cycles in 8 months of heavy use?

    Could it be another hardware error on the computer that caused the drive to corrupt? The reason I ask is that this computer previously had the SATA cable between the hard drive and logic board fail, and I had similar problems where the computer wouldn't boot. On the MacBook Pro I had before this one, that same part failed 3 times! It seems to be a pattern for me that I have SATA cables fail.

    Could it have been a software bug? The computer had some weird quirks since I got it back from my last repair. The repair depot installed Lion on it, even though it came with Mountain Lion. I upgraded it to Mountain Lion instead of doing a clean install. Something was odd with permissions in that I couldn't update iLife apps through the Mac App Store because it said that I had updates for a different user. I could never figure out what to do about that, but I always assumed it was a permissions issue, possibly caused by the depot installing Lion on a computer designed for Mountain Lion and possibly also installing iLife apps that had been registered to the depot instead of me. I don't know . . .

    I guess I'll figure out the answers to my own questions once I back-up, erase, and reinstall OS X on the internal drive and see if it boots. I'm just worried that even if it does work, that it may still be failing and corrupt again due to either the SSD failing or due to something else like the SATA cable.

    Any thoughts?

    Thank you. Sorry I wrote so much. This got me so anxious, I didn't realize how much I wrote--I literally penned this out in a couple of minutes and the words got away from me!



    When I tried selecting the Macintosh HD as the start-up disk from Startup Disk under System Preferences I got this message:

    You can’t change the startup disk to the selected disk.

    The bless tool was unable to set the current boot disk.

    That seems like an odd message for a disk that shows up OK under disk utility.

    Is this a clue as to what's wrong?
  2. ObeseSquirrel, Apr 14, 2013
    Last edited: Apr 14, 2013

    ObeseSquirrel macrumors regular

    Nov 22, 2011
    From my reply to your post in this thread: (post #92)


    Also, I think it's notable that Disk Utility was able to repair the disk on the cloned drive, but not on your main drive. Replacing the drive is probably your best first step.

    This is where I got my replacement SATA cable, if you want to go that route. (Obviously, you should check that you're ordering for the right model.)
  3. swingerofbirch, Apr 14, 2013
    Last edited: Apr 15, 2013

    swingerofbirch thread starter macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    Thanks very much.

    After backing up the hard drive (thank goodness I was able to do that at least after the clone's disk utility temporarily fixed the drive), I wasn't able to erase the SSD. It gives an error that the disk can't be unmounted. It gives the same error now in Disk Utility, too. Disk Utility seemed to have initially repaired the drive, at least to the extent that I could get the data off of it but not boot to it. But now when I try verifying or repairing it again it shows various errors, including the inability to unmount.

    I had heard that lay users never had to realistically worry about using an SSD too heavily, but I wonder if I did. It was 256 GB and I never filled the drive, but I did use it fairly heavily. Or maybe it was just a lemon.

    I guess I'll contact Samsung, although I'm not too interested in returning a drive to them that I can't erase.


    I tried booting from recovery mode again, and it couldn't erase the disk either. The strange thing is that System Report shows the drive and says that the SMART status is verified.

    I ordered a new internal drive from Amazon that I'll get Tuesday and will try that.

    EDIT 2: Does anyone know if there's a way to see how much you wrote to a drive if you can't boot to it but can see it when booted from an external drive? I can still see it in System Report under S-ATA devices. Is there any way possible a user could have written to a disk too much in 4 months? I mean, even if it were written to nonstop for 4 months would that cause total failure?

    EDIT 3: I just thought of something. I don't know a lot about Recovery partitions. But if I am able to boot into Recovery Mode, it would seem to me that that the recovery partition at least is writable, in that I believe something is being downloaded to the drive since I have to enter my Wi-Fi info. Could that be because there is something corrupted on the main part of the drive that is software related and still could be fixed (I'm not sure by what means . . .) that isn't affecting the recovery partition, or is it more likely that the recovery partition still works just because it wasn't written to like the main part of the drive?
  4. Fishrrman macrumors G5


    Feb 20, 2009
    Here's something to try:

    Take the problem SSD OUT OF the Macbook.

    Do you have another drive (even a slower HDD) that you can put into the MacBook in its place? Just to get the MacBook booted up and running?

    If you do, do that first.

    Now -- with the problem drive "in your hand", you need to connect it to the Mac. For situations like this, I highly recommend that you consider spending $25-30 for a "USB/SATA docking station". You can see these here:,k:usb3+sata+dock

    - Boot the MacBook with a working drive inside
    - Put the problem SSD into the docking station, connect it to the MacBook, and turn it on
    - The SSD should now "mount" on the desktop
    - Now, use Disk Utility to "attack it", erase, etc.
  5. swingerofbirch thread starter macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    Thanks . . . that's a good idea. I have a new internal hard drive arriving in the mail tomorrow. Once I get up and running I can try that . . . although I may call Samsung first and see what they say.
  6. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    The suggestion to hook the thing to a USB adapter and see what you can see is probably the best option, though it generally sounds very much like a failing drive to me. I wanted to weigh in on this, though:

    Exceedingly unlikely. That drive uses MLC NAND, which should have at least 3000 write cycles. Assuming that the wear-leveling routines in the drive are doing their job properly, you should theoretically be able to write 750TB of data before chips start to fail that it can't compensate for. Even assuming that the wear leveling is doing a poor job, you'd still expect 400+ TB of writes. That's well over 1GB of data per minute, 24x7, for the entire 8 months you've owned the drive. I seriously doubt you've used it THAT heavily.
  7. swingerofbirch thread starter macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    Good to know . . . and I actually was wrong, I've only been using the drive for 3 months. I bought it 8 months ago but didn't install until January.
  8. MacRobert10 macrumors 6502

    Nov 24, 2012
    The index files on your SSD are corrupt and the drive has been rendered "read only." A bad SATA cable can definitely cause problems like this. So can bad sectors or block (whatever you want to call them.)

    I followed this thread over from the "ObeseSquirrel" post. As he indicated Scannerz detected bad blocks on his SSD, so that should tell you they're not as infallible as their manufactures would have you believe they are.

    If the SATA cable is making intermittent contact during a write there's a good chance the data it puts on the drive is corrupt. I would caution about cloning a drive that you suspect is bad because any errors that it has in files will just be cloned right over to the "good" drive.

    I don't know what types of hardware you have available, but I would try to troubleshoot that problem in an orderly fashion. First, if possible, get the SSD out of the system. If the SSD is problematic and the OS is always trying to mount it, it will tie up and bog down your system.

    Second, create a new, good installation of the OS on a good hard drive in an external drive chamber, and I mean create it from scratch. Run the system using ONLY the external drive for a while and see if problems appear. If they do, you have a system problem. If not, you've localized part of the problem to the path from the I/O controller that interfaces to the internal HD to the internal HD.

    If this new drive is working OK, put it in as the internal drive for the system. If problems occur, then you know that it's either the SATA cable or the connections/traces on the logic board. If they don't then you know that it's the SSD causing the problems. If problems occur, then the only way to isolate it is to replace the SATA cable, and if the problems persist with a new SATA cable, the only thing left is logic board itself (OUCH!!!)

    The procedure I've just described is known as path isolation and SCSC has documents on it for Scannerz here: With Scannerz.pdf

    If you really want to get hairy, you can read this one:

    I really don't think the latter is needed (141 pages) because I think it's clearly intended to be used by techs.

    SSDs are changing and vary considerably from manufacturer to manufacturer. I think this is why so many people seem to be having problems with them. I swear I've read more about SSD problems in the last 3 months on various sites than I have about hard drives, but SSDs likely only comprise a small percentage of the market.

    Good luck.
  9. swingerofbirch thread starter macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    First, thank all of you for your great advice.

    Second, you might be a bit upset that I haven't followed all of your advice and yet I am still coming back from more.

    The main part I didn't follow was getting an external enclosure. I'm trying to be a bit expeditious or maybe expedient about this, I suppose.

    I received the new hard drive. It's just a run off the mill 500 GB SATA 2 HDD. So I swapped out the SSD and put in the new drive.

    My plan was to format it and do a clean install of Mac OS X. I believe (and I'm not sure if I'm wrong about this) that on a modern Mac you should just be able to put in a blank drive and start up to Internet Recovery to do that. But maybe I am wrong about that . . . ?

    I started up to Internet Recovery and when I chose Disk Utility the only drive showing was Disk0 (which had a globe next to it) and below that Mac OS X Base System. The Hitachi drive I bought was not showing up.

    I went instead to Install Mac OS X, and when I did there was no drive available to install to.

    I'm not quite sure where the 1.28 GB Mac OS X Base System was running from if it couldn't see the drive -- does it really just run a 1.28 GB system live off the Internet? I guess it must--otherwise you wouldn't be able to format a drive you're running from.

    I connected my external cloned drive (a clone made in February before the drive stopped working) and booted from that, and checked in the Finder and no internal drive was showing up.

    I went to Disk Utility from the cloned drive, and no internal drive showed up.

    I called Apple and . . . in short, I remembered why I don't like calling Apple, lol. They're very nice but of course they're going to start by mistakenly thinking you voided the warranty by replacing the drive, and it takes a half hour to explain everything to them. But I got them to send me a mail-in repair box.

    I did that because I assumed at this point that there must be an issue other than the hard drive, and I assume it's the SATA cable since that failed me once before on this computer, and twice before on the previous MacBook Pro I had.

    Am I wrong in assuming this? Should this have worked? I guess it's possible the new drive is a bum drive; after all, even the corrupted SSD showed up in Disk Utility.

    I'm guessing the only other troubleshooting I could do at this point would be to buy that external enclosure thing and see if the drive is visible from there. I'm guessing it would be, and I'm guessing there probably is a SATA cable problem, even though I don't really understand how the corrupted SSD was visible but the new drive isn't.

    My other question is how the hell do I keep burning through these SATA cables? Are they known to be the weakest link of a MacBook Pro? If that's what's wrong, this will be the fourth SATA cable over the course of two MacBook Pros to break on me in the last year or so. I wonder if it's that I use my computer too heavily and the heat causes them to fail? My computer does get pretty hot, but I've never known an Apple laptop that didn't get hot. I think Apple is suspicious of me (especially of the replacing hard drives part), and I'm starting to think it's strange too if that is again the issue.
  10. sjinsjca macrumors 68020


    Oct 30, 2008
    I would not trust that SSD again.

    Good quality SSDs will last for a good long while. But not all are of good quality.

    In part because your failed drive is a non-Apple unit, it's suspect. Replace it.
  11. swingerofbirch thread starter macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    I did replace it. The replacement drive isn't recognized, either, so I'm not so sure it was the SSD at at fault. The first time this happened to me three months ago, it was Apple's stock drive that became corrupted and that was a result of the SATA cable.
  12. sjinsjca macrumors 68020


    Oct 30, 2008
    Ah, sorry, read but didn't absorb the whole thread.

    Sounds like a warranty issue?
  13. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Yes, it should have worked; if the hard drive is connected to the computer and it's not showing up at all in Disk Utility (not as a volume, but as unformatted media), as you described, then either the drive is stone-dead, the cable is bad, or there's something wonky with the motherboard.

    Since you don't have an external drive case for a "second opinion" it's rather hard to completely rule out your new hard drive being coincidentally DOA (could you hear it spinning up when the computer was powered on?), but given the other symptoms the computer might have just failed more.
  14. swingerofbirch thread starter macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    Not a problem at all. Yup--it's with Apple now. I'm not sure what's wrong but guessing it's the SATA cable since I seem to have the magic touch that destroys those.

    Thanks, good to know. Just wanted to double check that. I don't remember whether the drive spun up or not. What ended up happening was that I sent the computer to Apple with the replacement drive, which works out well for me since I don't like sending data to Apple (paranoid, I guess). They stopped repair today and put it on hold and sent me a picture of "unauthorized parts" (the hard drive). I sent customer relations the part of the manual that says the hard drive is user serviceable so they made an "exception" for me and are continuing the repair. They said they are replacing my drive with a standard Apple drive so they can continue testing but will mail me my third party one, so that actually works out nicely for me. I'll have the Apple drive to swap back in if I have to send the computer back in again.

    The cost to continue the repair was going to have been $709 plus taxes! I have no idea where they came up with that number because at that point they hadn't worked on anything. They stopped working on the computer as soon as they saw there was a third party drive. Anyhow, I didn't have to pay that, so I'll find out soon what the problem was once they send it back.

    As I said, I'm now guessing it was the SATA cable. I maybe burn them out quickly due to using the computer a lot and it getting hot. That's my only guess. This last SATA cable, if that does turn out to be the issue, only lasted a few months.

    On the positive side of all this, I'm learning how to use a borrowed ChromeBook while my MacBook Pro is away . . .
  15. MacRobert10 macrumors 6502

    Nov 24, 2012
    I haven't opened up a unit like yours so I can't be sure, but some of those cables aren't really "cables" but a mylar like plastic with embedded copper traces. They can be notorious for getting cracks, hence intermittent disconnects, corrupt data, etc. etc. They're also very sensitive to handling because some of the copper traces can crack.

    The guys who make Scannerz used to have a video on their site that showed them (or someone) probing a faulty cable, and anytime they'd take a non-conductive probe to touch the SATA cable, which I assume was at least similar to yours, a bunch of irregularities (timing errors) would show up because of the intermittent disconnects. It's too bad they took the video down, probably because it wasn't very good quality, and it might have been provided by one of their customers.

    I don't mean to sound cynical, but I suspect that price is intended to be an "incentive" to buying a brand new computer instead of fixing the existing one.;)
  16. swingerofbirch, Apr 23, 2013
    Last edited: Apr 24, 2013

    swingerofbirch thread starter macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    Something is still failing . . .

    and I'm starting to feel like it's me!

    I'm kind of at a loss . . . I just got the computer back from Apple, and am still having problems.

    The repair took a long time because they stopped it seeing that there was a third-party hard drive. Rather than work on it with that drive, they free-of-charge took that drive out and put in an Apple-certified drive and did the repairs from there. It looks like the ended up replacing the SATA cable, which I expected, along with the logic board, which I did not expect at all (they noted video distortion as a symptom, which I didn't have before I sent it in).

    Anyhow, when I got it, I turned it on to make sure it works with the drive they put into it. I just got to the set up screen and then turned it off. My plan was to take out the Apple-certified drive and leave it blank and pop it back in if I ever have to send the computer back to Apple.

    I swapped back in the blank Hitachi 500 GB HDD that I had purchased to replace what I thought was a failing SSD.

    I booted to Internet Recovery. I formatted the drive to Mac OS Extended Journaled.

    Let me pause at this point to ask a question: The Hitachi drive presumably comes in NTSF. I assume Internet Recovery somehow boots from that drive. I don't quite understand how Internet Recovery can install on an NTSF drive, and also how can it format the entire drive to a Mac format when it's booted from that drive? I started wondering if there is something inherent in that that is the problem.

    Anyhow, it seemed to format it fine. Mountain Lion downloaded and then restarted. After about 10 minutes into the install I got a huge yellow triangle and error message that said something about there being an installation error and to restart the computer and contact the software manufacturer.

    I restarted the computer and it went straight back to the installation screen. Within seconds of starting, it says that there is a disk error that cannot be repaired and to restart. I restarted again and got the same error.

    I again booted to Internet Recovery and erased the drive. I then tried verifying and repairing and saw that there was an error that could not be fixed on the drive. I erased it again and then verified it again and got the same thing.

    So, thinking that the problem was that it was trying to repair the disk from a corrupted partition, I booted from my cloned drive (one cloned before the problems started), and there was an error message upon the desktop coming up saying the disk "Untited" (the new one) could not be repaired and that I should get files off of it as soon as possible. I tried running disk uility and erasing and then verifying the drive from the external clone, but had the same problems.

    I'm starting to wonder about a couple of possibilities: Is there some sort of bug with Mac OS X/Internet Recovery when it comes to third-party drives? Is that why the Apple repair depot was so insistent on getting the computer back to original specs before repairing? Or secondly am I damaging the SATA cable?

    I'm worried Apple is going to start thinking I'm the culprit. It's actually my dad who always switches the hard drives for me, as I'm not too technical. He says he's very careful. He always washes his hands and dries them very well before working on it.

    In the past when I've had issues like this he's also taken the hard drive out of my computer and into his identical MBP and tested it there to see whether it's the drive or computer, and he's never suffered any problems with his computer as a result of detaching and attaching the SATA cable.

    I'm guessing that's what I'll try next (as soon as my dad is available to help): taking this hard drive out of my MBP and putting it in his computer to make sure it's a functional drive and also putting the Apple-certified drive back in mine.

    The thing is that the drive they put in did work as far as I could tell. I just booted to the set-up screen and it turned it off. Although it's possible they imaged the hard drive with OS X before installing into the computer.

    Regarding it being a Mac OS X problem, I saw this:
    But it doesn't really seem related.

    I do recall the last time I had this problem and sent my computer into Apple, they sent it back with Lion. And when I tried doing Internet Recovery it was trying to install Mountain Lion. I don't know if that means anything.

    Sorry I'm sort of throwing a lot of spaghetti against a wall to see if anything sticks!

    Thanks for any ideas.


    I booted from the cloned drive again. I thought that perhaps trying to partition the internal drive (just to one partition) might help better than erasing it. I vaguely recalled doing that before when I had issues with a new external drive. It partitioned successfully. I then ran Verify on it again, and it passed. So, I detached the external drive, and then again booted to Internet Recovery. Just booting to Internet Recovery I got an error (which is one that appeared before I sent in the computer for repairs).

    The error is an image of the globe with a caution sign over it. Underneath it says and -501 0F.

    Update 2:

    Strangely Internet Recovery would boot sometimes with the new drive. And one time I even was able to repair the drive completely using Disk Utility after booting into Internet Recovery. But after I did that I decided to boot up to the Apple Hardware Test (holding down D) and it booted into Internet Recovery again with another error. I also noticed a very faint but very obvious fast clock ticking sound from the computer. I know hard drives can click, but I had never heard a fast clock ticking sound.

    I think I may have been confused in this whole process by trying to use Oczam's razor. It turned out there were probably multiple issues going on, including the brand-new replacement drive I bought from Amazon being a bum drive.

    My dad woke up in the middle of the night and kindly put the Apple drive back in. Everything is working fine, except that they inexplicably installed Lion rather than ML on it.

    I'm going to buy the external drive dock as suggested so I can further test the Amazon drive and also my SSD that I previously thought had been failing. I'm considering whether to erase the SSD and use that in the computer or not. It got corrupt enough that it couldn't be erased, but that was probably due to the faulty SATA cable. But for now I'll set it up with the Apple drive, and do that testing later with the external dock.

    Thanks for reading.
  17. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA

    The problem may well be your SATA cable, but it's not failing due to heat. If the computer was getting that hot, something else would fail WAY before the SATA cable.

    And it's certainly not failing due to overuse--unless the drive you have in there is using vastly more power than the cable is specc'd for, there's no way that any sort of use would electrically degrade the cable in any appreciable way over that sort of time scale. And if the drive was using that much power, I would expect the cable to burn out way sooner--almost immediately. But I have never once heard of that happening, ever, to any computer. I'd also guess that the power supply to the drive is limited at a current below what the cable can handle anyway, to prevent a fire in the event of a catastrophic drive failure, though it might not be. (I know from experience that the old candy iMacs weren't; I once hooked up the un-keyed optical drive cable backwards on one and melted right through the shielding on the cable... but that only took 10 seconds.)
  18. TheBSDGuy, Apr 26, 2013
    Last edited: Apr 26, 2013

    TheBSDGuy macrumors 6502

    Jan 24, 2012
    The fact that they replaced your logic board tells me they encountered problems they couldn't explain, assumed it was the logic board, and then replaced it.

    I doubt that there's specific drive requirement for your unit, but Apple did pull a stunt like this in one of the iMacs recently. However, the SATA cables are easy to break. They aren't simple cables, they can suffer from cracked traces and break easily. Some SATA cables are paired with drives for one-time installation, but I don't think your unit is one of them.

    Never, never, never blame POP!!!:D

    I would try the following:

    1. Boot the unit off the external drive and use it ONLY with the external drive, and see if any problems develop
    2. If problems develop, it likely means your problem has nothing to do with the drive and is something else in the system.
    3. If problems go away, it means that the SATA cable is likely damaged, you have bad luck, or Apple has made this unit compatible only with a few drives. I would think this unlikely, but since your unit is relatively new it could be possible this is a problem that hasn't been exposed to the rest of us yet.

    Mountain Lion, as far as I'm concerned, is a crap shoot. If you go to the Apple discussions board they're having problems with displays on Mac Minis, the problems you've linked on installation, application problems, etc. etc. etc. I had Mountain Lion on my system and cloned it off onto a FireWire external drive because the bugs with apps (Apple apps at that) were too numerous for me to put up with. I seriously couldn't get some work done because of the rampant crashes.

    Mountain Lion aside, I work fairly closely with SCSC, the makers of Scannerz, probably because if you call them up when you have a problem they actually answer the phone. :eek: During the development of their product, they determined that the leading cause of logic board failures wasn't actual component failure but the appearance of micro-cracks in things like traces on logic boards. What happens is that the traces are so thin on some of these, impact or even thermal fatigue may cause the traces on logic boards to crack, and due to heating and cooling, expand and contract thus yielding intermittent contact and erratic performance. They term these as "intermittent generic faults and failures." They are not limited to Apple products, they happen all the time nowadays. My old cell phone developed some and it's behavior became absolutely squirrelly.

    FWIW Scannerz can detect these during a surface scan because the product uses the surface scan progress as an indicator or errors and irregularities. If a surface scan on an SSD or HD is repeatable, the media (SSD, HD) is to blame, if it's erratic, it's most likely a fault of this type and it will show up as errors and irregularities that aren't repeatable with respect to the surface scan progress. This is why they refer to it as "fault detection software" rather than just "drive testing software" although I suspect they focus on the latter to sell the product.

    With that little diatribe complete, if you run only off the external drive and it works OK, it points to a damaged SATA cable. It could be the logic board, but since your's is now new, I doubt it. If it doesn't work OK, then there's likely an intermittent generic fault, not in the logic board or the SATA cable, but most likely in something related to the supply or the supply cables. It could possibly even be a problem with another plug in device to the logic board messing things up. Picture if you will, the drive in process of doing a write and then suddenly some other problem, such as an intermittent connection in the supply or a plug in causes a temporary reset. What happens? A screwed up disk, perhaps?

    If it was me, I'd try to boot off the external drive and see if it works without any problems for a week or so. If it does, it points at the SATA cable. If it doesn't (and I'm willing to bet it won't) I'd re-install the Apple provided drive, take it back to them, and tell them the problem isn't fixed. It may turn out to be nothing more than a little cable connecting the battery to the logic board, or something of that sort. I personally suspect the Apple people actually experienced some type of supply related failure and misdiagnosed it as a logic board failure, thus the new logic board. Pure speculation, of course.

    Finally, Mountain Lion is, in my opinion, the buggiest operating system I've seen since Windows 95. Trying to troubleshoot anything with that OS installed is simply complicating matters.
  19. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    You never used 10.0, did you?

    I really don't think ML has enough issues to significantly complicate troubleshooting, at least in a case like this. If the OP were using a Fusion drive, it would be a different matter, but I haven't seen any bugs overlapping with the sort of behavior the OP is seeing on the computers I've worked on.
  20. TheBSDGuy macrumors 6502

    Jan 24, 2012
    The bugs being encountered with Mountain Lion seem to be strange and erratic. On some systems like mine, they seem to be application oriented. For example, I've had problems with TextEdit crashing, iPhoto being unable to recognize that a camera is attached, and if it does, sometimes it crashes, I've had problems with X-Windows opening up application dialogs in the wrong workspaces, and a host of other problems. I downgraded to Lion because everything is working on it. Other people are having what appear to be hardware related problems such as external drives having problems (some Seagate Passports were apparently deciding to "take a nap" in the middle of read/write operations), others have problems with drives being recognized or crashing periodically, and a fair number of Mac Mini's are now experiencing "snow" on the display. Others, on the other hand, report no problems whatsoever. This is the strangest release of an OS I've ever seen. I suspect those with hardware related problems are related to the EFI change. I would also suspect this might be one of the problems the OP may be experiencing. This is speculation on my part.

    I find it interesting that Snow Leopard has now overtaken Lion and Mountain Lion as the apparent "preferred" operating system. All three are running neck and neck, but a recent study showed Snow Leopard is now king. I saw that on this site somewhere, but I don't have a link. This is the first time the "latest and greatest" has failed to achieve a clear number 1 spot as long as OS X has been around. Apple has continued to sell Snow Leopard, although you have to hunt for it, and this is another Apple first, to the best of my knowledge. I personally suspect that a fair number of users have downgraded to Snow Leopard to get away from bugs or "improvements" they don't like in both Lion and Mountain Lion. Once again, pure speculation on my part.

    As for 10.0, I forgive it for it's weaknesses, after all it was I believe considered to be an "experimental" release of the OS.
  21. swingerofbirch, May 6, 2013
    Last edited: May 6, 2013

    swingerofbirch thread starter macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    Another strange twist . . .

    I did purchase an external drive dock so I'll have it for future issues. Before deciding that the external HDD I purchased as a replacement drive was faulty and sending it back to Amazon, I plugged it into the dock. I ran Disk Utility on it and the first time it found an error with the upper level disk, nothing with the partition beneath it (just one partition). I repaired the disk. And I repeated the tests multiple times and no errors show up now. I erased the disk a couple of times, tested it again, and no errors show up.

    This is the same drive that I immediately put into the MacBook Pro when I got it back from repair that I could not install Mac OS X onto. I'm going to try installing Mac OS X to it now from the MBP through the USB to SATA dock. Will update with results.

    If I am able to do that, what would that mean?

    To recap, when I got it back, Apple had put a new 750 GB 5400 RPM drive in the machine. I took that out and tried this replacement drive, wanting to save the Apple drive for future mail-in repairs, and the drive wouldn't work. I put the Apple drive back in and it does work; although, the computer has been rather slow with beach balls galore (which might just be going from an SSD to a 5400 RPM HDD).

    Also, Apple replaced the HDD, SATA cable and logic board. If it's being funky and not accepting 3rd party drives, what would that leave to fix? Again, getting ahead of myself, I'll see if I can install OS X on this via USB-> SATA dock.

    Mountain Lion installed effortlessly on the replacement drive that I had previously thought was faulty (the 500 GB HDD) when I installed it via the USB->SATA dock. I was able to boot to the Mountain Lion set up assistant from the dock.

    Here's a new working theory: Maybe the computer has a problem where it will only deal with SATA 2 drives. There is no marking on the Apple drive to say either way, but maybe it's a SATA 2 drive. My SSD and the replacement HDD I bought are both SATA 3. The SATA 3 HDD works in the SATA dock, but not the MBP. Ergo, it could be a SATA 3 problem? However, the MBP was running the SSD which is SATA 3 with no apparent problems for a few months. And then the problem suddenly appeared.

    Alternative theory: Something more sinister is still wrong but doesn't show up with the Apple drive currently installed internal because the Apple drive was possibly imaged at the depot before being put into my computer and somehow the problem only shows up when doing a formatting/initial install of the OS on the drive? And maybe the slowness of this drive and beachballing is a symptom something is wrong, but the problem is less apparent because I'm not doing anything major like formatting the drive or installing an OS?

    I guess I can call Apple, but I just don't know who at Apple would know anything about problems like this. I don't think anyone would understand me. And I'm not sure what they could do even if they had an idea of what is wrong. Maybe there is another part to replace. Or maybe it's a software problem with OS X. Hmm . . .
  22. Fishrrman, May 6, 2013
    Last edited: May 7, 2013

    Fishrrman macrumors G5


    Feb 20, 2009
    "Mountain Lion installed effortlessly on the replacement drive that I had previously thought was faulty (the 500 GB HDD) when I installed it via the USB->SATA dock. I was able to boot to the Mountain Lion set up assistant from the dock.

    Here's a new working theory…"

    Stop with all the "theories", ok?
    You are reading way, WAY too much into all of this.

    You had a problem with the internal hard drive. You replaced the drive with a new drive, tested it, things seem to be ok.
    Just use the computer.

    - since you bought the USB/SATA dock (a VERY good decision, you are learning why), try this:
    - if you still have the OLD hard drive, put it into the dock
    - use Disk Utility (running from the computer) to re-initialize it and test it
    - does it mount on the desktop ok?
    - if so, I suggest you download the FREE version of CarbonCopyCloner (see note below)
    - Use CCC to create a "bootable clone" of your internal drive on old drive in the dock
    - Now, if you ever have a problem booting the internal, you can connect the dock, put the old "cloned drive" in, and "switch boot".

    NOTES on CCC:
    You can download the FREE (older) version of CCC from this page:
    The version you want is 3.4.7

    You will get an error message if you try to run this using Mountain Lion.
    DISREGARD the error message. Dismiss the alert, then close the web page you see.
    You will see CCC 3.4.7 running "behind it".
    It's OK to use this older version of CCC to create your bootable cloned backup. It will work fine.

    To switch boot:
    - Have docked drive connected and powered up
    - Restart
    - As soon as you hear the startup sound, hold down the option key and KEEP HOLDING IT DOWN
    - In a few moments, the startup manager will appear
    - Use the pointer to select the docked drive, then hit return
    - The computer will boot from the docked drive
    - I would suggest that if you use CCC to create a bootable clone, that you run through the above procedure at least once to check the bootability of the drive.
  23. swingerofbirch thread starter macrumors 68040

    Oct 24, 2003
    The Amalgamated States of Central North America
    I thought I would update this mainly because it's helpful for me to have a place where I can go back and look at the notes about this computer and I've already put a lot of details here.

    I had some problems even with the stock Apple drive after I got the computer back. First, it was installed with an older version of 10.7 even though the machine came with 10.8. The boot repair partition and Apple Hardware Test said they were incompatible with this Mac. The computer ran hotter than before, and I know this seems very strange but I swear it was heavier.

    Anyhow, it's had a lot of crashes—application crashes and crashes where everything stops responding and I have to power it down and restart. It also has a weird thing where all applications would quit and then reopen on their own. And it would also go black every once in a while and the screen would come right back on.

    So last night, I realized it had been putting out a bad smell. The whole day I had noticed an off, really weird smoke chemical type smell. And I had no idea where it was coming from. It was sort of like cigarettes but more dank and sickly like. I finally turned the computer around and put it to my face, and it was blowing out hot air that smelled. So I was planning to call Apple, when suddenly today everything crashed again like usual. Everything stopped responding. I shut down the computer and when I turned it back on, it came up to a flashing question mark.

    Even stranger, it wouldn't boot from my external clone for several hours. I left it alone and when I came back it would boot from the external clone (which I'm using at the moment), but it still won't see the hard drive.

    I am not sure how all this happened or keeps happening to me, especially since last time they even replaced the logic board.

    They want to attempt another repair and "really see what's going on" this time, which is something they say each time. This seems like it happens to me now every few months.

    As far as my data, I'm hoping it's there, as I don't have a really recent back up. But the drive isn't mounting. I'll try mounting it in the aforementioned external enclosure and see what comes up.

    Anyhow thanks for listening, and please feel free to respond, but I don't really have a question. Just wanted to log all this as I know I am much more likely to be able to find this thread again than notes somewhere else.

Share This Page