Is it normal for the new iMac to enter Safe Sleep after 4 hours without use?

Discussion in 'iMac' started by MartinAppleGuy, Nov 12, 2013.

  1. MartinAppleGuy macrumors 68020

    MartinAppleGuy

    Joined:
    Sep 27, 2013
    #1
    Got an iMac 21'' Late 2013. After 4 hours of the Mac not being used (and in sleep mode), when I go to awaken it there is a loading bar as well as the rest of the "enter your password screen" greyed out. This bar only takes 5 seconds. After the loading bar, I can enter my password. I believe this is a feature with all new iMac's since late 2012 because of power-saving an EU laws.

    Here is a page for the description of what it is:

    http://support.apple.com/kb/HT1757

    Have you had this happen to your new Mac (only happens when updated to Mavericks/ 10.8.2) and 4 hours of it being in sleep.

    Thanks :)
     
  2. MartinAppleGuy thread starter macrumors 68020

    MartinAppleGuy

    Joined:
    Sep 27, 2013
    #2


    Can someone answer me. Does anyone have a late 2012 or newer iMac, an put it to sleep over night?
     
  3. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #3
    It's clearly outlined in the support document.
     
  4. Chippy99 macrumors 6502a

    Joined:
    Apr 28, 2012
    #4
    I don't think it's as straightforward as that, is it?

    I have never seen safe sleep on my iMac, ever.
     
  5. MartinAppleGuy thread starter macrumors 68020

    MartinAppleGuy

    Joined:
    Sep 27, 2013
    #5
    Is your Mac running the latest OSX?

    ----------

    It only happens to me after 4 hours of it being in sleep mode, AND being connected to mains supply.

    ----------

    And it is only on late 2012 or later.

    So for it to happen, you have to-

    -have a Late 2012 iMac or newer
    -latest OSX updates
    -be connected to mains supply
    -left in sleep for more than 4 hours

    ----------

    So it is definitely nothing to worry about?

    ----------

    With the release of the OS X Mountain Lion v10.8.2 supplemental update 2.0, a new feature was introduced to enter safe sleep after four hours of the computer being connected to AC power. This is an effort to comply with the European Energy Standards (ErP Lot6). This will only occur if there is no wireless or Ethernet activity and no activity from external devices such as USB storage devices.

    This is normal behavior for the following models:

    MacBook Pro (Mid 2012 and later)
    MacBook Pro (Retina, Mid 2012 and later)
    MacBook Air (Mid 2012 and later)
    iMac (Late 2012 and later)
    Mac mini (Late 2012 and later)
     
  6. Chippy99 macrumors 6502a

    Joined:
    Apr 28, 2012
    #6
    Martin, I am surprised by your reply.

    You raised the original question asking if this is normal and now you are quoting Apple at me and telling me it is normal, answering your own question... which begs why you started the thread in the first place if you think you know the answer already. Very strange. I had read the Apple article already btw.

    Anyway, back to what I has said, no I have not seen this ever. I rarely power my Mac off (once a month perhaps) and I never unplug it. And I always put it to sleep every night, typically for 8 hours or so and often much more.

    And to repeat, I have NEVER seen it in Safe Sleep. This is with a late 2012 iMac running Mavericks and before that Mountain Lion latest version.

    So, no it is not as straightforward as it might seem.
     
  7. MartinAppleGuy thread starter macrumors 68020

    MartinAppleGuy

    Joined:
    Sep 27, 2013
    #7
    So is it a problem for me?

    ----------

    I never had it to start with when I got my Mac Late 2013. That was with Mountain Lion. I updated to Mavericks, then after a few days, it started happening. I did change one setting from default though in energy saving; that is the "wake for network access" to off. I also have "put hard drives to sleep when possible" switched on.
     
  8. jg321 macrumors 6502

    Joined:
    Aug 29, 2012
    Location:
    UK
    #8
    Mine's (late 2013 21.5") been asleep for days at a time and I've never seen it do the loading thing.

    I have an SSD only. I wonder if this is a factor?
     
  9. MartinAppleGuy thread starter macrumors 68020

    MartinAppleGuy

    Joined:
    Sep 27, 2013
    #9
    I have set the "wake for network access" and all appear to be fine. Problemo solved :)

    ----------

    It is to do with the "Wake for network access" option not being ticked. Ticking it has solved all problems for me :)
     
  10. jg321 macrumors 6502

    Joined:
    Aug 29, 2012
    Location:
    UK
    #10

    Are you saying that if you have the "Wake for network access" box ticked, it doesn't do safe sleep? This seems odd, as the default settings seem to have this ticked by default - so you'd expect no-one to see safe sleep unless they'd modified this setting?!
     
  11. MartinAppleGuy thread starter macrumors 68020

    MartinAppleGuy

    Joined:
    Sep 27, 2013
    #11
    Correct. Someone changed that setting on my Mac so when I ticked it, it doesn't safe sleep anymore. Remember that for a iMac, because it doesn't have a battery, the only reason it should enter safe sleep is because of no activity; both user activity and wireless/ethernet activity. The wake for network access option will power up the Mac to reconnect to the wireless connection so it has the activity. It is different on MacBooks though; as when there battery reaches a critical state of discharge; all contents of RAM will be written to backing storage.

    Hope this answers your question; I'm just glad I have solved it not just for myself but for others on the same boat.

    PS- the reasons people change the energy saving settings is so the monitor will power down when installing updates but not enter sleep. i.e untick the boxes.
     

Share This Page