Is it possible to change only the spelling check language?

Discussion in 'iPad' started by nalbagli, Apr 3, 2016.

  1. nalbagli macrumors 6502

    Joined:
    Sep 11, 2014
    #1
    Hi, I am having an issue with my iPad Pro that does not allow me to use it to it's full capacity, my issue is the following:

    - My native language is Spanish so most of my work is done on that language, but I do have an Apple Smart keyboard and use the U.S. International as my main keyboard layout because I am used to traditional english keyboards. My big issue is that when writing a paper on Microsoft Word in Spanish, the program automatically checks for the spelling on english so almost all the words in the document have the traditional red underline. So I wanted to know if it is possible to change the spelling check language but keep using the traditional keyboard layout that I am already used to?

    Thanks for the help
     
  2. Cascades42 macrumors 6502

    Joined:
    Jan 25, 2016
    Location:
    UK
    #2
    I added a second keyboard in that language, and then set the (hardware) layout to what I usually use. Then I just switch to the right language and the keyboard remains the same, but the spell check and autocorrect language changes.
     
  3. nalbagli thread starter macrumors 6502

    Joined:
    Sep 11, 2014
    #3
    Than
    Thanks that's what I tried the problem is that when selecting the keyboard layout I want, it does not give me the alternative of selecting mine on spanish, that alternative only appears on english I don't know why!
     
  4. JonnyBlaze macrumors regular

    Joined:
    May 5, 2008
    Location:
    UK
    #4
    Not sure if I've understood the problem correctly but first you add a Spanish keyboard in iOS settings. Then after you've done that, in the same settings menu you select the Spanish keyboard and you can choose from 'spanish' 'querty' 'azerty' or 'qwertz' layouts. You can do this for all keyboards you've chosen.
    Hope that helps, sorry if I've misunderstood your issue.
     
  5. nalbagli thread starter macrumors 6502

    Joined:
    Sep 11, 2014
    #5
    Hi thanks for the help, my problem is if I choose the spanish language the Keyboard layout I want (US International) is not available, that alternative only shows up if I choose english.
    I don't know if I am explaining it clear enough.

    Thanks
     
  6. Cascades42, Apr 30, 2016
    Last edited: Apr 30, 2016

    Cascades42 macrumors 6502

    Joined:
    Jan 25, 2016
    Location:
    UK
    #6
    Tap on the Spanish keyboard in settings > General > Keyboards, and then select QWERTY. It will use the usual key layout then. QWERTY is the standard layout. I just tested it and it works perfectly.

    Edit: 2 pictures to demonstrate:

    [​IMG]
    [​IMG]

    The second one I had already selected the Spanish keyboard. If you have a hardware keyboard there's the option to set the layout for that too:
    [​IMG]
     

Share This Page