Is it possible to disable spell check systemwide?

Discussion in 'OS X Yosemite (10.10)' started by ramparts, Oct 19, 2014.

  1. ramparts macrumors regular

    Joined:
    Jun 11, 2008
    #1
    I've just done a clean install of Yosemite, and in practically all of my apps I'm noticing those red underlines whenever I've "misspelled" something (or, more accurately, used an unrecognized name, technical term, piece of code, etc.). I have been disabling it app by app, although even then it doesn't always work - for example, when doing Google searches in Chrome it still shows up, even though I've disabled "check spelling while typing."

    I've also gone to System Preferences/Keyboard/Text and unchecked "Correct spelling automatically," but this still doesn't seem to do anything.

    Has something gone wrong on my system? And is there any more reliable way to completely disable this unwanted "feature?"
     
  2. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #2
    Is there a reason you don't want your spelling corrected?

    Are there certain apps that area doing it that it bothers you in? Many apps, like Office, Pages, etc... have their own spell check options. You might need to disable each one of those as needed.
     
  3. ramparts thread starter macrumors regular

    Joined:
    Jun 11, 2008
    #3
    My spelling (which is just fine, thank you) is almost never the problem. Instead it's things like code, technical terms, foreign words, etc. which tend to get those squiggly lines. That visual annoyance is completely not worth the rare instance where I misspell something and don't catch it.

    And I've been doing it app by app (with mixed results, as I mentioned), but it would be nice if there were a system-wide solution.
     
  4. kittencounter macrumors member

    Joined:
    Mar 22, 2013
    #4
    System prefs - Keyboard - Text - Spelling - Set up...

    Uncheck everything
     
  5. ramparts thread starter macrumors regular

    Joined:
    Jun 11, 2008
    #5
    The closest thing I have to that is System Prefs - Keybord - Text - "Correct spelling automatically," which I've already unchecked, as I said in my original post.
     
  6. kittencounter macrumors member

    Joined:
    Mar 22, 2013
    #6
    You have to go under Spelling: ..then choose "Set Up..."
    After that uncheck all the languages
     
  7. ramparts thread starter macrumors regular

    Joined:
    Jun 11, 2008
    #7
    I missed that! Thanks a lot. However I can't uncheck the very last language.
     
  8. ignatius345 macrumors 6502a

    Joined:
    Aug 20, 2015
    #9
    Ugh. This solution stopped working.
    I'm actually the one who posted that on the Apple Forums, by the way.

    Anybody got any other ideas? I'm seeing red underlines all over the place again, and have to play whack-a-mole with every app I use to shut them down.
     
  9. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #10
    It seems that there is only a global preference for automatic spelling correction, but not for spelling and grammar checking. This has to be disabled on a per-app basis in ‘Edit’ → ‘Spelling and Grammar’. Some applications, such as Chrome and MS Office, use their own spelling system.
     
  10. ignatius345, Nov 1, 2016
    Last edited: Nov 4, 2016

    ignatius345 macrumors 6502a

    Joined:
    Aug 20, 2015
    #11
    Awful. Every single time I respond using an iMessage notification bubble, it wants to (badly) spell-check the message and I have to right-click to shut it off -- only to find it's come back on next time. What a garbage feature.
     

Share This Page