Is it possible to unlock a 3G iPhone on 2.2.1 please?

Discussion in 'Jailbreaks and iOS Hacks' started by a27, Apr 4, 2009.

  1. a27 macrumors regular

    Joined:
    Jul 10, 2008
  2. redAPPLE macrumors 68030

    redAPPLE

    Joined:
    May 7, 2002
    Location:
    2 Much Infinite Loops
    #2
    i believe the answer is yes. i am not sure if macrumors like to read threads about unlocking (illegal) the iPhone (i might be wrong).

    but maybe you should try google...
     
  3. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #3
    Please search for this. There are two basebands; one works, one doesn't. Find out which one you have, and then read a guide on unlocking.

    Wow, no it isn't. It's protected by law, even. Have you been to the Hacks forum?
     
  4. benflick macrumors 68020

    benflick

    Joined:
    Jul 11, 2008
    Location:
    Cincinnati, Ohio
    #4
    The only way to do this is to use PwnageTool and keep the baseband at 2.28.00 so yell0wsnow will work. If you have already updated to 2.2.1, then most likely your baseband has been updated, and you're out of luck.
     
  5. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #5
    You'll have to use a hardware unlock, like a turbo SIM card, or whatever they like to call themselves :)
     
  6. a27 thread starter macrumors regular

    Joined:
    Jul 10, 2008
    #6
    How do I check my baseband?
     
  7. definitive macrumors 68000

    definitive

    Joined:
    Aug 4, 2008
    #7
    go to about in settings, and check modem firmware. if it's 2.28, then you can get 2.2.1 firmware with baseband removed, if it's 2.30, then you're probably out of luck unless there's a way to downgrade (some say there is, some say there isn't), or use a special SIM card.
     
  8. a27 thread starter macrumors regular

    Joined:
    Jul 10, 2008
    #8
    It is 2.30.
    Can you tell me of the alleged way to unlock 2.30?
     
  9. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #9
    They told you...special SIM card.

    **************************
     
  10. a27 thread starter macrumors regular

    Joined:
    Jul 10, 2008
    #10
    I meant the way to downgrade.
    Don't be so smug next time!
     
  11. benflick macrumors 68020

    benflick

    Joined:
    Jul 11, 2008
    Location:
    Cincinnati, Ohio
    #11
    You can't downgrade the baseband, just the firmware.
    Yellowsn0w will not work with the 2.30 baseband.
    Next time someone tries to help you, don't be rude to them. Just a thought.
     
  12. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #12

    Yes sir, that is what we are trying to tell you.
    As of right now, you cannot break the baseband to use Yellowsn0w.


    You will have to get a Sim card .
     
  13. a27 thread starter macrumors regular

    Joined:
    Jul 10, 2008
    #13
    Let-me-google-that-for-you is smug.
     
  14. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #14
    He already addressed that by saying that you were rude. It is irrelevant, anyway.
     

Share This Page