is iTunes 10.5 required to sync with iOS5

Discussion in 'iOS 5 and earlier' started by Invincibilizer, Oct 15, 2011.

  1. Invincibilizer macrumors 6502a

    Invincibilizer

    Joined:
    Aug 18, 2011
    #1
    I currently have iTunes 10.4, should i update to 10.5 so that its compatible with iOS5 or do I not need to if iTunes 10.4 works with iOS5?
     
  2. NorfolkMustard macrumors regular

    Joined:
    Oct 7, 2007
    Location:
    UK
  3. kappaknight macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #3
    Why don't you try it first and see what it says? It's pretty common knowledge here that you do need the latest version of iTunes to support the latest version of iOS - in this case, all the new iCloud features.
     
  4. Invincibilizer thread starter macrumors 6502a

    Invincibilizer

    Joined:
    Aug 18, 2011
    #4
    I am still going to use the data cable for transfers.

    I have no intentions of ever using iCloud.
     
  5. Cripps macrumors regular

    Joined:
    Jun 22, 2011

Share This Page