Is Macrumors running slower??

Discussion in 'Site and Forum Feedback' started by Pugpuppydude, Apr 17, 2009.

  1. Pugpuppydude macrumors regular

    Joined:
    Jul 31, 2008
    Location:
    Utah
    #1
    Hey guess, has anyone else noticed a massive lag in loading the homepage of macrumors? I have been on with like four different computers, one at my college with blazing internet, and it's still way slow? Are some servers down or something?
     
  2. themoonisdown09 macrumors 601

    themoonisdown09

    Joined:
    Nov 19, 2007
    Location:
    Georgia, USA
  3. Rt&Dzine macrumors 6502a

    Rt&Dzine

    Joined:
    Oct 8, 2008
  4. tman07 macrumors regular

    Joined:
    Mar 4, 2009
    #4
    I was thinking it was really fast, before I even saw this post...

    Must just be you! Sorry!
     
  5. michael.lauden macrumors 68020

    michael.lauden

    Joined:
    Dec 25, 2008
    #5
    maybe all of those computers have massive cache logs ha - it's fast for me too, and i have 1.5mb/s
     
  6. Little HZ macrumors regular

    Little HZ

    Joined:
    Nov 15, 2008
    Location:
    New Mexico
    #6
    I'm not having any problems (well, not on MacRumors, anyway ... :rolleyes:)
     
  7. fireshot91 macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
    #7
    Yupp, slower than usual for me. Maybe it's because I'm copying over 50Gb of movies to a external hard drive over USB 1. And that external is a IDE drive at 5200RPM.
     
  8. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #8
    Maybe arn accidentally downloaded a used newbie trojan.

    Some of those things are nasty and you never know what you'll catch from them. :eek:
     

Share This Page