Is magsafe silly?

Discussion in 'MacBook Pro' started by sioannou, Jul 13, 2011.

  1. sioannou macrumors member

    sioannou

    Joined:
    Mar 25, 2010
    Location:
    Nicosia Cyprus
    #1
    Hello , during the last day I came across a strange problem.

    I run my laptop on battery , and when I get the prompt that my laptop needs charging I connecting the magsafe. However, despite I am getting power the led does not goes orange. (to signal that is charging). Apart from that the system works like it is on power but the battery its not charging

    The problem happens randomly.

    any comments?
     
  2. ZStation macrumors newbie

    Joined:
    Jul 9, 2011
  3. Typswif2fingers macrumors 6502

    Joined:
    Feb 17, 2010
    Location:
    Dubai, UAE
    #3
    Simple thing first.. did you try to clean the connection surface... Apart from this, can you get a different adapter to do a test...

    And that is the knowledge about the issue I have... Whenever something analogue to your problem happens to me.. I swear and cry... :)
     
  4. sioannou thread starter macrumors member

    sioannou

    Joined:
    Mar 25, 2010
    Location:
    Nicosia Cyprus
    #4
    So you there isn't a possibility that this may be due to software issues?\
     
  5. randomrazr macrumors 65816

    Joined:
    Jan 1, 2011
    #5
    is the charge on ur macbook 95% +?

    if so, it wont charge inroder to save ur battery

    i
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    The original post lets you know that's not the case:
    OP, reset the SMC This should answer most, if not all, of your battery questions:
     

Share This Page