Is my airport card dead?

Discussion in 'Mac Pro' started by ndriver182, Oct 28, 2007.

  1. ndriver182 macrumors 6502a

    Jun 26, 2007
    I installed Leopard yesterday and was setting it up more today. The computer was in sleep mode for a while and when I came back there was a new keychain software update, which I then installed and restarted the computer as prompted by the installer. When the computer restarted I magically had no wifi signal anymore so I restarted the computer again (this has worked for me before). I still had nothing when I restarted. I clicked on the blank wifi symbol and it told me I have no airport card installed even though it's been working flawlessly for the last couple of months I've had the computer.

    I've tried restoring permissions (no idea if that would help anyway) and I unplugged the power from the back of the computer for a couple minutes and turned it back on, but nothing helped.

    Could the airport card just be toasted or is it possible there is just some sort of software conflict going on now? Like I said, everything was fine until I installed the "login & keychain update 1.0".
  2. product26 macrumors 6502a


    May 30, 2005
    doubtful, sounds as if it is software related.
  3. macosxguy macrumors newbie


    Sep 4, 2006
    London, England
    driver issue not bad card.

    I had the same problem with my 8-core mac pro. so I did an erase and install again and this time it works perfectly. Total pain in the ass but I think Leopard has so many little bugs that a clean start was my best offer. But the same thing happened to me right after the keychain update. No card found. I hear the issue is also affecting new iMacs. I did the clean install because that is what I did on my C2D Macbook pro and it has had no issues. Mac Pro was updated and it is full of issues. So I started from scratch.
  4. ndriver182 thread starter macrumors 6502a

    Jun 26, 2007
    Oh great. Just what I wanted to avoid. Since it's such a new install of everything for the most part. What are some opinions on just doing the "upgrade" install vs. wiping clean and install or archive install? I'd really like to avoid having to re-install all those apps as well as putting all my docs, music, etc. back on from my external drives. Can you even do an "upgrade" even with the OS already installed like that?
  5. scotsalmon macrumors newbie

    Oct 30, 2007
    Exact same thing happened to me...

    The craziest thing is that after installing Leopard, it rebooted and came up with enough network to register with Apple and download the two updates it wants to download right away when you install Leopard. Only after those updates did I lose my Airport. ARGH.

    [Edit: they found the solution for this here: -- delete /System/Library/Extensions/AppleAirport2.kext. Worked for me.]
  6. darthraige macrumors 68000


    Aug 8, 2007
    Coruscant, but Boston will do.
    From a different point of view:

    I don't have Leopard yet, but when I used my MacBook at someone elses house and connect to their wireless router it would work great still. I'd go back to mine and it wouldn't recognize it anymore. At first I thought the airport card blew up or something cause I never had it not detect it again. It was weird. The problem was my router settings. It someone changed the password on me, don't know how, but it did. Changed it back to what it was and it works fine now. But this is from a non-Leopard upgrade point of view. Sounds like it could be Leopard for you. Hard to tell. Hopefully I won't have that problem when I get Leopard. lol
  7. ndriver182 thread starter macrumors 6502a

    Jun 26, 2007
    I just put my leopard disc in and installed the "upgrade" option over my screwed up instance of the OS and it seemed to fix the problem and I didn't have to re-install everything I just spent hours installing prior to the keychain update. Everything *seems* to be running fine so far and no real performance problems as far as I can tell.
  8. derickO macrumors newbie

    Oct 30, 2007
    I had the same problem with my iMac and Powerbook wireless cards after installing the online Login and Keychain update. both computers just said there was no card installed and there was no way i could activate it. So I called Apple and the guy said to do this: go to Mac HD > System > Library > Extensions > AppleAirtPort2.kext and delete that file. Then i think you just restart....Both of my wireless cards are working fine right now. Though Leopard has messed up other parts of my computers significantly... Hope this helps!

Share This Page