Is my computer fried - continued kernel panic

Discussion in 'MacBook Pro' started by tresa73, Jul 8, 2010.

  1. tresa73 macrumors newbie

    Joined:
    Jul 8, 2010
    #1
    Okay, I will start with I spilled water underneath my closed and asleep laptop 2 days ago. I have had the thing 2 years and never spilled anything on it before. I wiped it up promptly and honestly didn't even think any water got into it. I tried to turn it on and it didn't turn on right so I shut it off, took the back cover off and then later in the day when I finally could figure out how disconnected the battery on the nonremovable battery. I figured at this point my warranty was void anyhow so what difference did it make if I broke the battery worse.

    Let the computer dry... fast forward to computer turn on. The first time I turn it on it takes me to my login screen with my name, but the keyboard won't let me type in my password. So I hold the shut off button and leave it alone again thinking well maybe something is wet in the keyboard. Next time I turn it on I get the ""You need to restart your computer. Hold down the power button for several seconds or press the Restart button."

    I cannot get my computer to load at all, just that. So I scour the internet and I can get it to load the second disk and do the Apple Hardware Test. It comes back fine. I cannot get it to boot from install disk. (There is a small scratch on this disk so it is possible the disk is the problem, but honestly don't want to spend more money on a disk if my computer is shot.)

    I also can get it to start holding command S and command V. When I go to command S as I have seen some of the posts suggest I type in the fsck -fy command and it will tell me "Checking Catalog file. Incorrect block count for file pcscd.pub (It should be 16 instead of 17)"

    It will go through and repair and then say File System Was Modified, run again get The volume Macintosh HD appears to be OK. But of course still doesn't work on start up. Next time I start with command S will get the same error running fscky -fy.

    Tried starting with command V and it will run through until it gets to this point

    AirPort: Link Down on en1
    en1: 802.11d country code set to "US'
    en1: Supported channels 1 2 3 4 5 6 7 8 9 10 11 5 6 7 8... (bunch more numbers sorry typing manually)
    Jan 1 08:32:58 teresas-macbook-pro ntpdate[97]: can't find host time.apple.com
    Jan 1 08:32:58 teresas-macbook-pro ntpdate[97]: no servers can be used, exiting
    Jan 1 08:32:58 teresas-macbook-pro mDNSResponder[56]: mDNSKeychainGetSecrets: Could not copy keychain default
    Jan 1 08:32:58 teresas-macbook-pro mDNSResponder[56]: SetDomainSecrets: mDNSKeychainGetSecrets failed error 2313 CFArrayRef 00000000

    and then it stops.

    I will also add that I am not super tech smart, but I do know how to read and follow instructions. I have nothing to lose by trying to fix it and I do not have the money right now to buy a new laptop. I am really upset though as all my good programs are on this computer and my other computer is a Vista laptop so I can't use any of them. I have also lost some files, although not much as most of my stuff is backed up.

    So two questions: One, can I put my macbook install disk into vista to see if the disk is broken (just to look at it and see if there is stuff on it that loads) or will that break my Vista laptop. I am not about to be without any computer so if there is a chance it will break that not doing it!

    Two: Is there any chance my laptop is fixable? Anything else I can try???
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    If you only kept the laptop asleep and didn't remove the power cable/battery when the laptop got wet. There's a very good chance you shorted the logic board.

    Power is still coursing through the laptop when the computer is put into sleep.

    It is fixable - you (or apple) will need to replace the logic board and given that its water damaged, it won't be covered by the warranty (if you had applecare).
     
  3. tresa73 thread starter macrumors newbie

    Joined:
    Jul 8, 2010
    #3
    Well fixable is good news. I turned it off immediately, but since it has a nonremovable battery in it I didn't know how to remove the battery right away. That took a little bit of searching. Plus I had to go to the store to get a small enough cover to pull off the back of it so it took me a while to get the battery removed. I didn't think it was even fixable so I will take fixable if that's an option, but if anyone knows anything else I can try let me know as I am sure this isn't a cheap fix.
     

Share This Page