Is my firewire dead?

Discussion in 'Mac Basics and Help' started by zathras, Feb 18, 2006.

  1. zathras macrumors member


    Nov 6, 2005
    North AL
    Computer: iMac G5 iSight running 10.4.5

    Tonight I wanted to grab a home video in iMovie and make a DVD of it. I hooked up my moviebox DV and iMovie kept on saying "No Camera Attached." So I try my DV camcorder - and same thing.

    I tried both of them in my iBook and they both were recognized right away.

    I then tried booting in Target disc mode both ways from iMac to iBook and vice versa. Nothing.

    I noticed that in System Profile on the iBook it shows the info for the connected device and on the iMac nothing is shown on the firewire screen - it just has:

    FireWire Bus:

    Maximum Speed: Up to 400 Mb/sec

    Any ideas or will I be sending my Mac back for service :(
  2. 2nyRiggz macrumors 603


    Aug 20, 2005
    Thank you Jah...I'm so Blessed
    Try another Firewire device and see if the imac sees it.

  3. zathras thread starter macrumors member


    Nov 6, 2005
    North AL
    I tried every devide I had.

    I tried resetting nvram

    and I even tried turning the iMac off for an hour or so.


    What I didn't do was unplug the Mac when I shut it down.

    I just shutdown and unplugged it for about 5 minutes - plugged it in and bam - its back.

    sorry for the extraneous posts but maybe it will help someone :)

Share This Page