Is my Mac G4 MDD dead?

Discussion in 'PowerPC Macs' started by M C STORM, Jan 7, 2008.

  1. M C STORM macrumors newbie

    Jan 7, 2008
    Firstly, thanks for taking the time to read my post.

    I have a Dual 1Ghz G4 mirror Drive Door PowerPC at home.

    I had upgraded the ram to 2gb (same sticks as the original) and added an matched (same as original) 80GB drive as a secondary, It worked fine for about 6 months at home then it started hanging every so often randomly and you had to do a hard reboot (holding the power button) however it would not boot back up. Gets to the Apple logo screen then after a few mins to a blank blue screen and no further, I had to boot from a disk and run disc repair on that drive where it reported “invalid HFS header (or volume, cant quite remember)” and it manages to repair it every time.

    I presumed it the drive was on its way out so replaced it with 40GB IDE drive from another machine which I know works, copied the image from the old drive to the new drive and it booted fine, worked for a day then the same thing started happening again, its very random, sometimes its fine for hours and it will just freeze up.

    So if its not a drive issue do you have any ideas what else it could be? I’m hoping its not a duff IDE controller as if that’s the case then I’ts for the bin which would be a shame as it’s a cracking wee computer.

    Appreciate any advice you can offer. :)
  2. CJRhoades macrumors 6502

    Dec 4, 2007
    Lafayette, IN
  3. 4JNA macrumors 68000


    Feb 8, 2006
    looking for trash files
    nice call! i always want to look at 'what's changed' or 'what's in common' when dealing with the crazy 'sometimes' problems. i would also yank/remove the added ram and see what effect that has, with power cord unplugged of course.

    while you have it unplugged and open, i would remove and reseat all cards that are installed, and if there are any you no longer use, then remove them all together. limit the size of the problem/problems you are chasing!

    also wonder if you create a new account and log in to the new account if you have the same problem. best of luck.
  4. kumar303 macrumors newbie

    Feb 14, 2008
    still dead?

    Hi. I have the same mirrored door G4 and I first experienced this same thing several weeks ago. This is running OS X 10.4.11 (something around there anyway, can't check it now). I too thought it was the HD and replaced it, now it's happening again with the new HD. Sometimes it even gets past the blue screen and drops into a Darwin/BSD console asking me to login at the prompt. This makes me wonder if it's software related. Something is really F'd up because it won't accept my password at the prompt and this doesn't seem like a shell, ^C doesn't escape out of the login.

    I started up in verbose mode and here are some suspicious messages: database /var/db/CodeEquivalenceDatabase opened READONLY (R/W/ failed errno=30) error writing entropy file /var/db/SystemEntropyCache

    ...then it seems to get caught up here, outputting this message repeatedly:

    SystemStarter[37]: Waiting for application services

    (repeats about 50 times)

    ...then finally it loads Apple File Service, printing services, Apache web server. Then says:

    SystemStarter[37]: printing services did not complete

    [I see a blue screen for a second]

    SystemStarter[37]: Waiting for IFC
    (this repeats 50 times)

    then finally, freezes on the blue screen


    Before I try to replace the HD ribbon did the original poster find a solution?

    thanks, Kumar
  5. Firefly2002 macrumors 65816

    Jan 9, 2008
    Just replace the ribbon cable... not worth bothering to wait for a reply. It's not like it really costs anything, and it only takes like ten seconds.

    They can be serious culprits.

    Anyway, if the ribbon cable doesn't work (it might not), you might want to get Diskwarrior. For Tiger, that's Diskwarrior 4... for Panther you could use DW3, though I think DW4 might work on it too.

    It probably said "Invalid HFS Volume Header." That's generally a directory issue.. which Diskwarrior specializes in. Of course, if you already have TechTool Pro, use that. Otherwise, buy DiskWarrior. Or, get it by some other means.

    I strongly doubt your MDD is dead.

    If all of that doesn't work, you could always try an add-on PCI/ATA card, or if you don't' mind the trouble, a new SATA card with new SATA HDDs.
  6. M C STORM thread starter macrumors newbie

    Jan 7, 2008
    Sorry for the late reply.

    I backed up my stuff, formatted the HDD and installed Leopard and it been perfect now for weeks so looks like it was a software issue rather than hardware.

    Good luck! :)
  7. NaniNanette macrumors newbie

    Aug 7, 2009
    Hy guys.

    Im a girl from Holland and im experiencing the excact same problem. The same errors occur when i start up with cmnd+v.
    He found a solution by backing up and install the software again?
    Could someone please explain me by steps how to backup my stuff when im not able to start my iBook?

    Installing the software shouldnt be a problem for me, but then again, im a girl ;)

    please reply asap because i just got my iPhone 3gs and i was about to sync it :(


Share This Page