Is my optical out broken? (audio help needed)

Discussion in 'MacBook Pro' started by marklight, Nov 26, 2008.

  1. marklight macrumors 6502

    Joined:
    Apr 6, 2006
    #1
    I have a MBP from Feb 2008. I used to be able to use an optical cable sending audio to my Bose home theater receiver. It's been a long time however since I've tried to do this, as I was using an Apple TV for a while, but now I'm all into Plex. I went to use my optical out on my mac, and it's not working at all. I remember a while ago I think I tried to use it and it didn't work as well, but this was a few months ago.

    I bought a new one, but still nothing. I don't see any kind of light coming out of the end of either cable I have. I have Perian installed, - I set it to multichannel output. In the sounds option, I've made sure to have Digital Out selected. In the audio midi control panel I have:

    Built in Output settings - Source: Digital out 48000khz ...default output and system output are set for built in output.

    I remember a while back, when i was trying to ac3 passthrough to work with quicktime, I followed some guide to change a setting... but I don't remember where or what it was.

    Thanks for any help or suggestions.
     
  2. Cave Man macrumors 604

    Cave Man

    #2
    Mark,

    If you're using Plex, you should have digital audio out turned on (for both DD and DTS if your receiver support it). Once you start playing a video with DD or DTS, your receiver should automatically detect it.

    Don't trust QT (with or without Perian) for this as it is too quirky.
     
  3. marklight thread starter macrumors 6502

    Joined:
    Apr 6, 2006
    #3
    I'm not getting sound coming out from it at all... whether im using Plex, quicktime, or iTunes... there's no light coming from the end of the cable (i've used multliple cables)
     
  4. Cave Man macrumors 604

    Cave Man

    #4
    Hmm. That's peculiar. In the System Preferences > Sound > Output tab, do you have Digital Out selected?
     
  5. marklight thread starter macrumors 6502

    Joined:
    Apr 6, 2006
    #5
    yea if you read through my post you'll see that I pretty much looked over every option i know about. I'm just pretty sure I should at least see light coming from the end of the cable if there's a signal going through it...
     
  6. Cave Man macrumors 604

    Cave Man

    #6
    Oops, I missed that. Anyway, I just plugged in an optical cable to my MBP and launched DVD Player, set it to Digital Optical from its Preferences panel and started Ghost in the Shell rip. Sure enough, there's a red light coming out the other end of the Toslink cable. Somethin' strange happenin' with your MBP.
     
  7. DYER macrumors 6502

    Joined:
    Oct 4, 2008
    Location:
    London, UK
    #7
    it sounds like your optical has indeed died.. an easy way to test it is if you have an adapter for the headphone jack to normal optical cable and just put the adapter in and have a look if there is a red light the light will come on immediately by default no matter what you are doing
    good luck
     
  8. marklight thread starter macrumors 6502

    Joined:
    Apr 6, 2006
    #8
    yea i plugged it into another macbook and it instantly output light. This is pretty frustrating. I was just wondering if there was some kind of setting I shut off or switched to make it not output optical.
     
  9. OrangeSVTguy macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #9
    Well you still have AppleCare left. Take it in before it's too late!
     

Share This Page