is SDK 4.0 official?

Discussion in 'iOS Programming' started by MACloop, Jun 16, 2010.

  1. MACloop macrumors 6502

    Joined:
    May 18, 2009
    Location:
    Germany
    #1
    Hi,
    is SDK 4.0 the official SDK for iPhone development now? In the apple developer portal it is marked as beta, but it seems like you are available to put apps developed with this sdk into the app store since 10 of June...?

    My question:
    - should I overwrite my SDK 3.2.2 with the new 4.0? Should I have those 2 parallell installed?

    - is iPad development possible with only 4.0 installed (Xcode etc 3.2.2 is overwritten).. i found some information saying that the 4.0 only is for development for iPhone/iPod?

    - what about multitasking and iPad?

    - will I be able to build and run apps on a device with the OS 3? In other words: If I have an old iPhone which cannot have the OS4 installed - is it possible to use the new SDK for development on such a device?

    Thanks in advance!
    MACloop
     
  2. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    I don't think it is yet the current approved version. Yes, Apple is accepting apps for the app store built with the 4.0 GM SDK.

    Personally, I'm keeping two installations. 4.0 and 3.1.3.
     

Share This Page