Is slight UI lag normal?

Discussion in 'MacBook Pro' started by LanceHudson, Mar 16, 2017.

  1. LanceHudson macrumors newbie

    Joined:
    Nov 25, 2016
    #1
    Hi,

    I am suffering from slight UI lag on a 2016 15". It's minimal, but still noticeable. Such as 0.5s lag and choppy transition into fullscreen mode. Closing windows, as well, is met with lag of about half a second. I know it's small, but definitely noticeable - and gets quite annoying. I don't see this is an issue to take it back to the Apple Store, but do you know any way to fix it?

    15" with 460 Pro

    I've also had a poor experience with local Apple Store when having shutdown issues, and even though I was in return period, seemed angry when I asked to return it so I did it online. So, I'd rather not bring up such a minor issue like this, especially as I'm now out my return period.

    Thanks.
     
  2. ZapNZs macrumors 68000

    ZapNZs

    Joined:
    Jan 23, 2017
    #2
    No, I do not believe this is normal. There is no lag on my nTB 2016, and with the 15's I have used I have not personally noticed UI lag, and I would have noticed as UI lag is a pet peeve of mine.

    Have you already ruled out that this could be caused by any third party software or a usage-based scenario?
    Have you ran Disk Utility First Aid, reset the PRAM and SMC?
    Have you tried reinstalling macOS and performing the Apple Diagnostics to check for hardware issues?
     
  3. Hieveryone macrumors 68020

    Joined:
    Apr 11, 2014
    #3
    yea it might be I mean i ahve the base 2.0 13" new macbook and it's slower than my 2013 one in terms of just a side to side launching apps and stuff comparision albeit unscientific
     

Share This Page