Is the Legacy App reporting under Systems Report Always Accurate?

Discussion in 'macOS Mojave (10.14)' started by jaybar, Apr 28, 2019.

  1. jaybar macrumors 6502a

    jaybar

    Joined:
    Dec 11, 2008
    #1
    I am beginning to question the 32 bit warning system in Mojave. I installed a 32 bit app from Cisco (AnyConnect) and upgraded to their 64 bit version and I still get warnings.

    More alarming was the i then uninstalled the app and it still appears in the legacy part of my systems report.

    Both are concerning.

    Thanks
     
  2. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #2
    The entry in Legacy Software shows the path to the app. Go see if it exists.
     
  3. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #3
    The “legacy software” section in System Information is neither up-to-date nor comprehensive. It seems to list just those programs that you have used recently and it takes some time to clear the list.

    Screenshot 2019-04-29 at 00.35.34.png

    Screenshot 2019-04-29 at 00.40.34.png

    However, if you are still getting a warning when opening a program then this might indicate that there is still a component that is not 64-bit. At least I have not encountered this.
     
  4. martyjmclean macrumors 6502

    martyjmclean

    Joined:
    Jan 24, 2018
    Location:
    Sydney, NSW, Australia
    #4
    A "64-bit app" may still have 32-bit dependencies or helper apps. I work in Avid Media Composer, which is like that.

    Try running
    Code:
    system_profiler SPApplicationsDataType | grep -B 6 -A 2 "(Intel): No" > ~/Desktop/non64bit.txt
    in Terminal instead?
     
  5. jaybar, May 5, 2019
    Last edited: May 5, 2019

    jaybar thread starter macrumors 6502a

    jaybar

    Joined:
    Dec 11, 2008
    #5

    There is something very strange and I hope someone can comment. I upgraded the app (Cisco AnyConnect) to the latest version, which is supposedly 64 bit and fully compatible with Mojave. It still appears in the system report under “legacy”.

    However, when I install the same version on my High Sierra partition, which shipped with my iMac, the same app is listed as 64 bit. Moreover, all the component (helper) apps are also listed as 64 bit.

    How can it be 32 bit it one OS and 64 bit in the other. Identical versions of the app in both instances.
     
  6. NoBoMac macrumors 68020

    Joined:
    Jul 1, 2014
    #6
    How it seems to behave, if you invoke something that is 32-bit, it's basically logging this and staying in the log.

    Case in point, I tried to invoke Office 2011 on my new Mac (TimeMachine restored), could not due to activation server issues. Deleted Office as really don't need, yet, still shows up in the list of Legacy software (been off the machine for over a month now).
     
  7. jaybar thread starter macrumors 6502a

    jaybar

    Joined:
    Dec 11, 2008
    #7

    It’s more complex. If I run it today in the Mojave volume, it appears under legacy, with today’s date. It I run it today in the High Sierra volume, it lists it as a 64 bit app. Both run today.
     

Share This Page

6 April 28, 2019