Is the new iMovie laggy and slow for everyone else? or is it just me?

Discussion in 'Mac Apps and Mac App Store' started by maf2k8, Oct 22, 2014.

  1. maf2k8 macrumors 6502

    Joined:
    Jul 14, 2009
    #1
    I have been a long time user of iMovie '09. Its really smooth and has no lag, The audio when moving the slider across the video tracks is perfect.

    Well last month i decided to purchase the new iMovie, I figured it was time to upgrade and the new iMovie had to be better., Right? Well i have iMovie 10.0.6 and it just seems so slow and laggy.

    I usually make videos for YouTube. I record some 1080p clips with Quicktime and my Sony HDR-CX150 camcorder and then import the video clips into iMovie. When i drag the clips down to split them and edit them, It just seems jittery and laggy. When running my cursor across the video clips the audio is so robotic sounding. Just everything about the new iMovie seems jittery.

    iMovie 10.0.6 is nice if it wasn't so laggy and slow.

    I have a new 27" i7 iMac with 512ssd and 8gb ram. Even when i used the newest iMovie on my 2009 i7 iMac it had the same laggy issues.

    Is the problem my machine? or is this how the new iMovie is?

    I keep going back to the old iMovie because its so fast and smooth but i do like some of the new effects the new iMovie has.

    If this issue is common with the new iMovie, Can anyone recommend a good alternative to iMovie? Nothing to complicated but at the same time, Nothing to featureless and generic?

    Thanks
     
  2. 960design, Oct 22, 2014
    Last edited: Oct 22, 2014

    960design macrumors 68020

    Joined:
    Apr 17, 2012
    Location:
    Destin, FL
    #2
    iMovie running great for me. Created a video a couple of days ago with no problems.

    Running MBPr / Yosemite / iMovie latest.
     

    Attached Files:

  3. kcrossley macrumors member

    Joined:
    Mar 22, 2009
    #3
    I'm having the same issue with a MacBook Pro i7. Did you ever find a solution?
     

Share This Page