Is there a bug with language switching in Sierra?

kylera

macrumors 65816
Original poster
Dec 5, 2010
1,196
27
Seoul
I have a 2016 12" MacBook. I regularly switch between Korean and US English, and I'm noticing that every now and then, there seems to be a problem with switching languages.

I would hit my keyboard shortcut (cmd-space bar) to switch languages, but the language flag stayed the same. At first, I thought I was just not used to the keyboard because it's one of the thinner keyboards. However, even when I held the command key after hitting the space bar once to get the menu of available input languages and manually selected the other language, it still wouldn't switch. The flag at the top right corner of the screen stayed at one language.

Strangely enough, when I cmd-tab to a different app, and then cmd-tab back into the app where I want to type, the language has switched.

I don't know how to replicate this bug. What's for sure, however, is that I never witnessed this in older versions of OS X.
 

airlied

macrumors 6502
Jul 8, 2011
381
56
Yes. I have had the different issue with inputs since El Capitan. I frequently switches between Japanese and English. I dont know about Korean but in Japanese you've got Katakana and Hinagana so I basically have 3 input turned on (but i dont think that's why I got the issue).

And every now and then either Japanese or English input stops working. The flag at the right cornor did change with keys. But the inputs themself dont.

for example. If im using pages, and switching between chrome and pages when I type something in english on chrome then switch back to pages to type something in Japanese, the language wont change even if the icon changed. and if this issue happened it stays.No matter what the icon is the actual input would be either english or Japanese.

I have to reboot the mac to fix it, but it comes back few hours after the machine being heavily used.
 

kylera

macrumors 65816
Original poster
Dec 5, 2010
1,196
27
Seoul
Yes. I have had the different issue with inputs since El Capitan. I frequently switches between Japanese and English. I dont know about Korean but in Japanese you've got Katakana and Hinagana so I basically have 3 input turned on (but i dont think that's why I got the issue).

And every now and then either Japanese or English input stops working. The flag at the right cornor did change with keys. But the inputs themself dont.

for example. If im using pages, and switching between chrome and pages when I type something in english on chrome then switch back to pages to type something in Japanese, the language wont change even if the icon changed. and if this issue happened it stays.No matter what the icon is the actual input would be either english or Japanese.

I have to reboot the mac to fix it, but it comes back few hours after the machine being heavily used.
In the Keyboard preference, input sources tab, did you activate "Automatically switch to a document's input source"?

I'm going to go a few days without this box checked. It's going to make typing more inconvenient, but I'm going to see if there is consistency.
 

kylera

macrumors 65816
Original poster
Dec 5, 2010
1,196
27
Seoul
Yes, seeing this intermittently. Input language switches, but displayed language doesn't - until it does :) but not sure what triggers it to switch. I'm just dealing with it for now, will see if it's resolved in 10.12.2
My issue is slightly different. I'm typing this in English, but the label still says Korean on the menu bar. I don't think I've seen it switch to English at all today

I'm seeing some kind of pattern here.

I switch regularly between Korean and English. This issue only pops up when I go from English to Korean, but not Korean to English. It's still intermittent; I can't determine what triggers it, but I have trouble when switching from English to Korean while switching the other way around works as intended.

@airlied, can you see if this issue is the same with Japanese input?
 

kylera

macrumors 65816
Original poster
Dec 5, 2010
1,196
27
Seoul
Yes, that's what I meant - I didn't describe it clearly. The language is changing (i.e. the actual keyboard functions) but the display isn't, reliably.
Sheesh. What did Apple do to OS X to result in a bug like this, I wonder.
 

FreakinEurekan

macrumors 68040
Sep 8, 2011
3,388
327
Eureka Springs, Arkansas
No telling. It's pretty harmless as bugs go, I hadn't even given it much thought until I saw your comment about it. Mostly I just change languages with the mouse instead of the keyboard shortcut to avoid it.
 

pickaxe

macrumors 6502a
Nov 29, 2012
759
266
It's pretty harmless as bugs go
I completely disagree, it's gotten to the point that I get it on every single input language change. In fact, I'm just about to go back to El Capitan. The only new feature I actually had a use for in Sierra, pressing Caps Lock to change input language, also stopped working about 2 weeks ago, so there's literally not a single reason for me to stay.
 

kylera

macrumors 65816
Original poster
Dec 5, 2010
1,196
27
Seoul
No telling. It's pretty harmless as bugs go, I hadn't even given it much thought until I saw your comment about it. Mostly I just change languages with the mouse instead of the keyboard shortcut to avoid it.
Harmless maybe in terms of not crippling the system, but from a usability standpoint, it destroys your workflow if you swap between two or more inputs on a very regular basis.
 

kylera

macrumors 65816
Original poster
Dec 5, 2010
1,196
27
Seoul
Input method changing between Chinese and English has the same issue.
Are you seeing this equally going either way, or is this more prominent going one way?

It's been five days since I've made my post, and I've definitely been able to isolate it to one direction - English to Korean. Korean to English always works, but English to Korean needs that extra cmd-tab to a different app.
 

zhaoxin

macrumors 6502
Jan 28, 2015
263
50
Are you seeing this equally going either way, or is this more prominent going one way?

It's been five days since I've made my post, and I've definitely been able to isolate it to one direction - English to Korean. Korean to English always works, but English to Korean needs that extra cmd-tab to a different app.
This issue on my iMac has multiple behaviors. In input settings, I enabled switching input method by Caps-lock key. When everything works fine, here are the behaviors should be:

## Correct behaviors
Using caps-lock to switch Chinese input method and English. That means:
1 when using Chinese, press caps-lock will turn input method to English
2 when using Chinese, long press caps-lock will turn input method to Capital English, green light will be on in Apple Magic Keyboard.
3 when using English, long press caps-lock to switch to Capital English, long press caps-lock to go back
4 when using English(whether Capital or not), press caps-lock to switch to Chinese

## Incorrect behaviors
### first(very common)
1. pressing caps-lock does switch input method, but the indicator in menubar doesn't change accordingly at all.
### second(very common)
1. pressing caps-lock does not switch input method any more. But cmd+space still works. menubar indicator works as well.
### third(less common)
1. press caps-lock and cmd+space both don't work. I have to use mouse to click the menubar indicator to switch input method.
### fourth(rare)
1. press caps-lock and cmd+space both don't work. Even more, when I use cmd+space, I could see only the English input method or the Chinese input method was gray. Both were gray in cmd+space and in menubar indicator.

The Chinese input method I use is the `pinyin`input method that is delivered with macOS.
 

airlied

macrumors 6502
Jul 8, 2011
381
56
My issue is slightly different. I'm typing this in English, but the label still says Korean on the menu bar. I don't think I've seen it switch to English at all today

I'm seeing some kind of pattern here.

I switch regularly between Korean and English. This issue only pops up when I go from English to Korean, but not Korean to English. It's still intermittent; I can't determine what triggers it, but I have trouble when switching from English to Korean while switching the other way around works as intended.

@airlied, can you see if this issue is the same with Japanese input?
Yes, the issue is the same with Japanese input.

And I have tried both "Automatically switch to a document's input source" box checked and unchecked you mentioned before, for few days. the issue stays.

However, I do find a 'way' to solve this issue. Im using Japanese layout keyboard (the same apple wireless keyboard but with Japanese Hiragana on it). The keyboard actually has two additional keys to switch input that normal English layout doesn't have. which are 'English', and 'Kana'. When issue appears and other way doesn't works, the two physical keys works. So Im currently using these key.

I dont know if Korean keyboard has similar physical keys or if you are using Korean keyboard. So this might be not for you.
 

niji

Contributor
Feb 9, 2003
1,465
1,174
tokyo
i have not encountered this issue with mac OS Sierra.
before Sierra however i encountered similar issues where placing the cursor into a field that had Japanese in it already would not allow me to get back to inputting Japanese.
the only thing that worked was to open up a totally new document and get it back to a situation it could figure out, then going back to my older document.
however, in Sierra I go back and forth continuously between English, Japanese, and Burmese and there are no problems currently that I encounter.
OS itself is set to English and I use only Unicode fonts and built in apple keyboard layouts.
 

kylera

macrumors 65816
Original poster
Dec 5, 2010
1,196
27
Seoul
i have not encountered this issue with mac OS Sierra.
before Sierra however i encountered similar issues where placing the cursor into a field that had Japanese in it already would not allow me to get back to inputting Japanese.
the only thing that worked was to open up a totally new document and get it back to a situation it could figure out, then going back to my older document.
however, in Sierra I go back and forth continuously between English, Japanese, and Burmese and there are no problems currently that I encounter.
OS itself is set to English and I use only Unicode fonts and built in apple keyboard layouts.
It's funny - your timing of this post eerily coincides with me realizing how I haven't encountered this issue for quite some time now.

I have no idea what's going on, but I'm not complaining.
 

=alex=

macrumors newbie
Oct 17, 2014
8
3
It's funny - your timing of this post eerily coincides with me realizing how I haven't encountered this issue for quite some time now.

I have no idea what's going on, but I'm not complaining.
This bug is so annoying.

It's pretty consistent for me. Whenever I switch between English and the Pinyin input method using cmd+space, and immediately typing, the switch never works. I have to switch back to the original input method, then switch to the intended input method, and then wait for a second or two before I can type using the intended input method. Basically, after switching using cmd+space, I must wait for a second or two before I continue typing to avoid this bug. Using mouse doesn't seem to cause a problem in the workflow as it naturally takes more time before I move my hand back to the keyboard.
 

SaSaSushi

macrumors 601
Aug 8, 2007
4,079
470
Takamatsu, Japan
I use cmd+2 for Select next source in Input menu and cmd+1 for Select the previous input source.

Is cmd+Space the MacOS default? It's been so long I can't recall. I've been using the shortcuts above for the 11 years since I started using Macs to switch between English and Japanese and have never experienced the problem described in this thread.

I could have sworn that cmd+Space was the default keyboard shortcut for Spotlight though...

At the moment, it invokes Siri for me.
 

kylera

macrumors 65816
Original poster
Dec 5, 2010
1,196
27
Seoul
I use cmd+2 for Select next source in Input menu and cmd+1 for Select the previous input source.

Is cmd+Space the MacOS default? It's been so long I can't recall. I've been using the shortcuts above for the 11 years since I started using Macs to switch between English and Japanese and have never experienced the problem described in this thread.

I could have sworn that cmd+Space was the default keyboard shortcut for Spotlight though...

At the moment, it invokes Siri for me.
I could be wrong, but cmd-Space was the default for me on OS X El Capitan, and ctrl-Space was for Spotlight...though I want to say that was the case in older version of OS X...but I could be wrong. There's still a page about that here: https://support.apple.com/kb/PH21564?locale=en_US

However, I know for a fact (because I recently reinstalled Sierra on a Mac) that cmd-Space does bring up Spotlight by default on Sierra.
 

kyrsquir

macrumors newbie
Aug 6, 2017
1
0
It appears that removing cmd+space shortcut from Siri settings fixed that for me. I'm unable to reproduce that bug for a few hours already.
 

=alex=

macrumors newbie
Oct 17, 2014
8
3
It appears that removing cmd+space shortcut from Siri settings fixed that for me. I'm unable to reproduce that bug for a few hours already.
Thanks, it works for me too!

Why does Apple use the same shortcuts for two different functions? :eek:
 

SaSaSushi

macrumors 601
Aug 8, 2007
4,079
470
Takamatsu, Japan
Thanks, it works for me too!

Why does Apple use the same shortcuts for two different functions? :eek:
Technically they do not. Siri is invoked by "hold command space". Both keys have to be pressed and held for a few seconds. Just tapping will not work, much like a single press of the home button of an iPhone serves a completely different function then press and hold for Siri.
 

=alex=

macrumors newbie
Oct 17, 2014
8
3
Technically they do not. Siri is invoked by "hold command space". Both keys have to be pressed and held for a few seconds. Just tapping will not work, much like a single press of the home button of an iPhone serves a completely different function then press and hold for Siri.
You're right. Must be a bug in determining whether it's a hold or not... I surely don't hold it for more than 1/4 of a second when switching languages...