Is there a fix for the iPhone not working in 802.11g mode?

Discussion in 'iPhone' started by OzyOly, Dec 29, 2010.

  1. OzyOly macrumors 6502a

    Joined:
    Jun 3, 2009
    Location:
    Melbourne, AU
    #1
    So I think it's pretty well known that the iPhone simply doesn't operate correctly on G networks and the easiest way to fix it, is to set your router to 802.11B mode where, despite crippling speeds for everything else on the network, actually makes wifi on the iPhone usuable.

    The problem I have with this is that I like my N/G networks, I like how fast they are with my macs, pcs, xbox 360 and even android phones. Wifi is just unstable with my iphone 4 yet is blazing fast on my mate's HTC in G mode.

    Have apple acknowledged the problem with wifi and promised a fix or have the swept it under the carpet? :confused:
     
  2. wacky4alanis macrumors 6502

    Joined:
    Mar 18, 2009
    #2
    It works fine for me with my router in g/n mode. Maybe it depends on the wireless router? Mine is a lousy Netgear router that Comcast gave me for free.
     
  3. OzyOly thread starter macrumors 6502a

    Joined:
    Jun 3, 2009
    Location:
    Melbourne, AU
    #3
    I'm also using a cheap router, by thompson that O2 (UK) gave me and it doesn't work with just the iPhones. Same goes for really expensive corporate cisco access point at Uni though...
     
  4. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #4
    I have no problems with my iPhone 4 to my Airport Extreme router (which is set to g/n mode)
     
  5. OzyOly thread starter macrumors 6502a

    Joined:
    Jun 3, 2009
    Location:
    Melbourne, AU
    #5
    Have you compared it to another phone on your network? My home internet connection is only 4Mb downstream and I get nearly that speed over B on the iPhone but it seems 10x slower on G.
     
  6. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #6
    I have a 7mb downstream link and I get that consistently on my iPhone (or iPad or any other device) everywhere in the house: I get exactly the same speeds reported as my Wife does with her 3GS
     

Share This Page