Is there a Imessage available for download?

Discussion in 'macOS Sierra (10.12)' started by theslaz, Nov 9, 2018.

  1. theslaz macrumors 6502

    Joined:
    Dec 12, 2009
    Location:
    Calgary; Alberta; Canada
    #1
    Running a Imac with MacOS Sierra 10.12.6 My Imessage app was not working, so in all my wisdom I thought I would uninstall it and start over. Should have checked first to see if there is a replacement app. I checked via Google and can't find one. There has to be a way to get this back on my system. I do have the system backed up, so I could restore it. Just checking if there is another way!
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    You won't be able to find the app anywhere stand alone. Just command-r boot to recovery and reinstall the OS without erasing anything and it will put the Messages app back.

    Backup first just to be safe.
     
  3. theslaz thread starter macrumors 6502

    Joined:
    Dec 12, 2009
    Location:
    Calgary; Alberta; Canada
    #3
    Thanks. That is what I suspected. The reason I wanted to have a clean install of the app was that I could not change my password for gmail in the app. I have just recently changed my password for Gmail, and I suspect that is why the app refuses to work.
     
  4. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #4
    What app is this exactly? I didn't think the the regular Messages app supports anything aside from Apple's iMessage and perhaps SMS/MMS (so no Google/Gmail accounts or anything like that).

    https://support.apple.com/en-us/HT202549
     
  5. theslaz thread starter macrumors 6502

    Joined:
    Dec 12, 2009
    Location:
    Calgary; Alberta; Canada
    #5
    Its the messaging app that comes with the operating system. All I know is that when I set it up, it asks for my Google account password.
     
  6. theslaz thread starter macrumors 6502

    Joined:
    Dec 12, 2009
    Location:
    Calgary; Alberta; Canada
    #6
    The latest on my predicament. I restored my system to a good TM backup, going back 3 days. Didn't work. Can't get the boot page past the progress bar going half way and than a black screen Have tried numerous different booting scenarios with negative results. Right now waiting for my attempt at a second restore going back 6 days. Fingers are crossed!
     

Share This Page

5 November 9, 2018