Is there a (jailbroken) way to force disable badges for a certain app?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Mystikal, Feb 27, 2011.

  1. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #1
    I am trying to disable badges for the Facebook app, and even though they are disabled in the settings, they still show up. Is there a way to disable notifications for just that app? Maybe something on the file system? This is very very annoying.
     
  2. lanulos macrumors regular

    Joined:
    Jun 19, 2010
    #2
    The Cydia app No Badges will suppress all badges, but I'm guessing that's not what you want. But I am puzzled why they still appear when you have them turned off. I never get any. But I almost always disallow notifications when installing apps. Perhaps you need to reboot? Or delete the Facebook app and then reinstall, disallowing notifications?
     
  3. Mystikal thread starter macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #3
    I have tried that. For some reason the settings stick. If I delete, reboot, install, reboot: the settings are still there and it gives me no option to disallow notifiations.
     
  4. jordan314 macrumors newbie

    Joined:
    Feb 28, 2011
    #4
    This is annoying me too. Ever since facebook implemented their new messaging system, I have a new badge saying I have 50 unread messages, even though 1) facebook messages are also emailed to me so why read them again? and 2) they're mostly spammy messages from events anyway. I turned off badge notifications and restarted the phone, marked a couple messages read and reopened facebook, but the badge is still there.
    It's also annoying that facebook does't have a "mark all as read" function. I'm surprised this bug circumvents the Apple notifications API but it wouldn't be an issue if their site had that function.
     
  5. Joey113 macrumors newbie

    Joined:
    Jul 29, 2011
    #5
    YYou should just hide the icon in SBSettings it worked for me

    Open sbsettings click on more and got to hide icons and turn off the icon you wish to hide
     

Share This Page