Is there a way to turn off that red up and down arrow that flashes on screen

Discussion in 'Site and Forum Feedback' started by motulist, Jun 13, 2015.

  1. motulist macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #1
    Overall I think the new macrumors look is fine, no better or worse than the original - HOWEVER, I #$^*'ing hate that stupid red up and down arrow box on the lower right hand of the screen that pops up and disappears every time you scroll the page. PLEASE tell me how to turn that fricking piece of crap OFF!
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    Agreed. That thing is redundant and intrusive.
     
  3. motulist thread starter macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #3
    Exactly. It's very standard interface convention that things which are red and suddenly pop on screen are supposed to mean "IMPORTANT!!! LOOK AT ME!!!" So every time I fricken slightly scroll the screen all of a sudden there's a thing shouting "IMPORTANT!!! LOOK AT ME!!!", but it's actually the *least* important thing on the screen.

    And also exactly like you said, every web browser in existence already has a built-in controller to scroll up and down on a page, so the extra arrow box is *completely* useless. In fact it's anti-useful - it makes navigating the site *harder*, not easier.
     
  4. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #4
    Maybe with a style sheet, but that's beyond my expertise.

    Keyword, for forum search purposes: Stylish
     
  5. motulist thread starter macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #5
    I don't know anything about stylesheets. There really should be a preference setting to turn it off. I looked through macrumors preference settings but i didn't see a setting for this.
     
  6. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #6
    The arrows are triggered by Javascript, however this CSS should effectively move them out of your sight:
    Code:
    #uix_jumpToFixed{
        right: 100% !important;
        bottom: 100% !important;
    }
     
  7. motulist thread starter macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #7
    Hah, I think you overestimated my knowledge when I said I don't know anything about stylesheets. What Exactly am I supposed to do with that code?
     
  8. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #8
  9. motulist thread starter macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #9
  10. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #10
    @motulist, you can download the stylish extension for Safari here, or if you use Firefox here.

    If you want an extension-less approach in Safari, save the code using a plain text editor to a file with a .css extension, and make it your user stylesheet in Safari > Preferences > Advanced > Style sheet > Other.
     
  11. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #11
    I've been using "display: none !important;" which I think is a little more elegant than moving it off the screen :)
     
  12. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #12
    Oh, I had assumed the JavaScript overrides that. Very well:
    Code:
    #uix_jumpToFixed{
        display: none !important;
    }
     
  13. OLDCODGER, Jun 13, 2015
    Last edited: Jun 13, 2015

    OLDCODGER macrumors 6502a

    Joined:
    Jul 27, 2011
    Location:
    Lucky Country
    #13
    I am using Omniweb, and am useless at coding, so I did the following to rid myself of this pest:

    When arrows appear, right click on them and select "inspect element"
    Find "uix_jumpToFixed" and expand.
    Untick all lines in that section.

    Pest gone!

    Er ... only until Quit. Rats!
     
  14. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #14
    Thanks for the style sheet and css fix, gents. Much nicer without the red arrows.
     
  15. OLDCODGER macrumors 6502a

    Joined:
    Jul 27, 2011
    Location:
    Lucky Country
    #15

    Well, I tried, really tried (on Omniweb), and failed.

    Did I mention that I am useless at coding? "sigh"
     
  16. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #16
    To select a custom style sheet (a sheet, a file, that includes only your preferred customisations):

    OmniWeb preferences for the macrumors.com domain – page appearance – style sheet – custom.png
     
  17. OLDCODGER macrumors 6502a

    Joined:
    Jul 27, 2011
    Location:
    Lucky Country
    #17
    Many thanks, grahamperin. I did know about that, but I don't know how to follow simple instructions on making a text css (see my post No: 15).

    I followed redheeler's instructions to the letter (so I thought), but no dice, I'm afraid.
     
  18. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #18
    @OLDCODGER try something like this:

    something like this.png


    – and use OmniWeb to select that file then save the workspace, quit, relaunch the browser and revisit the workspace.

    Or if you have just one MacRumors Forums page open, simply close then reopen the window to that page.

    Here: OmniWeb 6.0 test (v625 r219164) on Mavericks. (Not the most recent test build; I don't use Yosemite.)
     
  19. OLDCODGER macrumors 6502a

    Joined:
    Jul 27, 2011
    Location:
    Lucky Country
    #19

    YAY! Getting Omniweb to save the file, instead of TextEdit, did the trick! Many, many thanks! :)
     
  20. motulist, Jun 14, 2015
    Last edited: Jun 14, 2015

    motulist thread starter macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #20
    I installed the stylish extension for safari, and it puts an "S" button in the toolbar, but it doesn't do anything when I click on the S button, and in safari's extension's preferences stylish is there but it has no settings. I'm on safari 5.0.5 (the newest version for the OS I'm running), and the extension installed fine, and shows up with the "S" button, etc., but I don't see how to make it do anything.

    EDIT:

    Whoops, sorry, I just did a fresh install of OS X, and I did one software update cycle, but I forgot that you have to repeat it several times to get all the way up to date. I'll update my system when I'm home later and see if that fixes the problem.
     
  21. d4rkc4sm macrumors 6502

    d4rkc4sm

    Joined:
    Apr 23, 2011
    #21
    i killed my neighbor's dog because of that thing. my neighbor doesnt know and i'm still working on my anger issues.
     
  22. motulist thread starter macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #22
    I did this (see attached screenshot), but the arrows are still there.
     

    Attached Files:

  23. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #23
    I'm not familiar with that app that you're using, but it looks like you're not specifying #uix_jumpToFixed anywhere.
     
  24. motulist thread starter macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #24
    That's the "Stylish" extension that I was told to use. Where do I type in #uix_jumpToFixed ?
     
  25. AngerDanger macrumors 68030

    AngerDanger

    Joined:
    Dec 9, 2008
    #25
    In the CSS box, which already has display: none !important; in it. Once you're done, the box should contain:

    Code:
    #uix_jumpToFixed{
    display: none !important;
    }
     

Share This Page