Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

sonictonic

macrumors 6502a
Original poster
Mar 25, 2006
954
11
San Jose, California
...at the same time?

I picked up a really cool wireless USB speaker set and want to use it with my current gen iMac running Snow Leopard. Problem is that as far as I can tell, and I've done some searching, that it's either the USB audio, or my internal iMac speakers, one or the other - not both.

Do any of you guys know a way I could use both outputs at the same time? Internal speakers and the wireless USB ones?

I hope there's a way. Thanks in advance for your time. :)
 

upaymeifixit

macrumors 6502a
Feb 13, 2009
787
1
I've actually wondered this too, so I googled it. Right now I'm on this, but if that doesn't work I will try this.

EDIT: If you open up Audio MIDI Setup and create a new aggregate device with your USB and internal out does it work?
 

sonictonic

macrumors 6502a
Original poster
Mar 25, 2006
954
11
San Jose, California
Hey thanks for your reply... Unfortunately the second link is a little over my head :eek: ... and the Apple support article, though it sounded great, didn't help either. Those screen shots don't even look like mine, which makes me think those are not Snow Leopard captures. Also, I don't at all understand why, but when I click the + sign to add the "aggregate device" NOTHING happens. If I have either the "Wireless Audio" or "Built-in Output" selected in the source list on the left, when I click the plus sign the selection just goes to the top of the source list, which is "Built-in Microphone" and nothing happens.

Why can I not add this new combined device! It sounded like it'd be so easy! :(


EDIT:
Figured out since my main user account is not an Admin I couldn't do it unless I logged into my Admin account. So that part worked and I added the new profile, added both internal and wireless devices to it, BUT it does not work. Sound only comes out of the internal, AND I lost control of my volume. WTF?

So for now I put it all back, until someone figures this out for me. :p
 

upaymeifixit

macrumors 6502a
Feb 13, 2009
787
1
The Apple Support page is actually for leopard, but it's the same idea. I haven't been able to do it, but did you hit the + in the bottom left? After that you select on the right the output devices you want to use. Then from the gear icon in the bottom left you make that your default output. Did you do all that?
 

sonictonic

macrumors 6502a
Original poster
Mar 25, 2006
954
11
San Jose, California
The Apple Support page is actually for leopard, but it's the same idea. I haven't been able to do it, but did you hit the + in the bottom left? After that you select on the right the output devices you want to use. Then from the gear icon in the bottom left you make that your default output. Did you do all that?

Yeah, did you see my edit above? Still only sound comes out from the internal speakers... :(
 

sonictonic

macrumors 6502a
Original poster
Mar 25, 2006
954
11
San Jose, California
lol I did before making this post... had no luck. Yours worked with the audio setup utility? Are you using internal + wireless USB speakers just like me?
 

upaymeifixit

macrumors 6502a
Feb 13, 2009
787
1
lol I did before making this post... had no luck. Yours worked with the audio setup utility? Are you using internal + wireless USB speakers just like me?

Nope, I'm using the headphone jack. I think that's why it doesn't work for me.
 

zacl87

macrumors member
Sep 19, 2009
73
0
Yeah, I doubt you can divert the sound to two separate outputs, but I'm not 100% of that.
I use LineIn - http://www.versiontracker.com/dyn/moreinfo/macosx/18987 to rout my aggregate device to whatever output I want, but I obviously use an actual line in.

If you aggregate your wireless speakers in audio midi setup, then choose them as your input in line in, with your output being built in speakers they will play out of your computer speakers, not sure if they will physically still play themselves though. Also i'm not even 100% that LineIn will be able to use a wireless aggregate.

Anyway, something to try. Good luck!
 

soms

macrumors 6502
Dec 10, 2007
412
12
Seattle
You probably could cobble together something with Line-In and Soundsource, but I've got no way of testing it out here.
 

sonictonic

macrumors 6502a
Original poster
Mar 25, 2006
954
11
San Jose, California
You probably could cobble together something with Line-In and Soundsource, but I've got no way of testing it out here.

Could you elaborate please, would you mind?

I downloaded Soundsource and am using it to at least easily change output devices when I need to without having to dig into system prefs, but I still ideally would like both outputs. I'm about to give up though since nothing has worked and it sounds not do-able.
 

LVsFINEST

macrumors newbie
Mar 16, 2011
1
0
Sonictonic, did you ever find a solution? I have the exact same issue as you and been to both links upaymeifixit offered before even finding this thread. I have the same behavior with MIDI, only built-in speakers would play when the aggregate output was selected. I was also unable to control the volume of this via my keyboard, so I assume even if all speakers played and the aggregate worked, we'd still lose volume control. I haven't tried Sunflower or any other software, I'd like to be able to do this via OSX, not 3rd party. Even my extra speakers aren't 3rd party (Apple Cinema display built-in + iMac built-in). I thought for sure this would "just work".
 

gnomeisland

macrumors 65816
Jul 30, 2008
1,094
829
New York, NY
Hey I posted this on another thread, sorry for the repeat. As someone mentioned you can use the LineIn program but I just discovered the dirty and stupid simple solution. You use Soundflower (another free audio utility) and TWO copies of LineIn (just rename them and they'll both launch just fine).

1. Use Soundflower 2ch. as your default audio
2. Open up both copies of LineIn
3. Make sure you can see both copies of LineIn (they will open right on top of each other)
4. Direct each from 'Soundflower 2ch.' to one of the outputs you want.
5. Hit "Pass Thru" and your golden.

More steps than setting up an iMac and its a dirty, dirty workaround for a stupid limitation but there you go.
 
  • Like
Reactions: bobesch

BenTristem

macrumors newbie
Aug 16, 2012
1
0
Simple solution found

I found a simple solution that requires no extra software...

1. Open Audio MIDI Setup app (built-into Macos)
2. Click the + at the bottom left, see screenshot below
3. Choose "Create Multi-Output Device" see screenshot
4. Click on it and choose your two sound devices

... should work find, may take a little fiddling to get volumes right.
 

Attachments

  • Mac multi sound output.jpg
    Mac multi sound output.jpg
    207.5 KB · Views: 966

bigwillsmall

macrumors newbie
Nov 13, 2011
3
0
Thanks

Thank you - This was quick and easy worked great!:)

I found a simple solution that requires no extra software...

1. Open Audio MIDI Setup app (built-into Macos)
2. Click the + at the bottom left, see screenshot below
3. Choose "Create Multi-Output Device" see screenshot
4. Click on it and choose your two sound devices

... should work find, may take a little fiddling to get volumes right.
 

tommybunnz

macrumors newbie
May 14, 2013
1
0
TWO Sound Outputs Remedy!

I have been pondering over this for quite some time now, as multiple things happen in my office. I'm outputting sound for FCP editing out of my MBox 2 and also while working, I like to have my HD TV running as well. For me, the solution was this:

1. Open Audio Midi Setup in Utilities folder.
2. At the bottom left click the + to add a new device for sound. (Aggregate Device for OSX Leopard and Snow Leopard)
3. To the right of your screen you will see a list of your sound output options.
4. Choose the 2 that you would like to use. ( For me it was my VIZIO, and my Mbox2)

This is the tricky part.

5. Change the clock source at the top to the HDMI output.
6. Click Configure Speakers (bottom right)
7. It should now say at the very top "The Aggregate Device Has 4 channels in 2 streams)
8. Since you chose the HDMI output as your Clock Source, Stream 2 should be checked and routed to channels 3-4 and Stream 1 should remain unchecked.
9. Click Apply

This did the trick for me now. I'm able to hear Final Cut Pro out of my Mbox2 and hear Netflix from my TV all while being run from my CPU. If you have to, rearrange the two streams and the channels they are assigned to.

Part 1

attachment.php


Part 2

https://forums.macrumors.com/attachment.php?attachmentid=412255&stc=1&d=1368579073

Part 3

https://forums.macrumors.com/attachment.php?attachmentid=412256&stc=1&d=1368579073

Part 4
https://forums.macrumors.com/attachment.php?attachmentid=412257&stc=1&d=1368579073

Part 5
https://forums.macrumors.com/attachment.php?attachmentid=412258&stc=1&d=1368579073
 

Attachments

  • Part I.jpg
    Part I.jpg
    331.1 KB · Views: 8,834
  • Part II.jpg
    Part II.jpg
    69.1 KB · Views: 964
  • Part III.jpg
    Part III.jpg
    136.2 KB · Views: 940
  • Part IV.jpg
    Part IV.jpg
    47.5 KB · Views: 889
  • Part V.jpg
    Part V.jpg
    14.2 KB · Views: 5,181
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.