Resolved Is there any way to install 4.2 or 4.3 on iPod Touch 2Gen?, How?

Discussion in 'iPod touch' started by dreamersofeden, Jun 16, 2011.

  1. dreamersofeden, Jun 16, 2011
    Last edited: Jun 19, 2011

    dreamersofeden macrumors member

    dreamersofeden

    Joined:
    May 26, 2011
    Location:
    Spain
    #1
    Hi,

    Im trying to upgrade and JB the iPod Touch 2G of a friend but can't install the "official" last firmware for this model (4.2.1). iTunes downloads it but after that it says that my model isn't elegible for that IPSW... WTF? :confused:

    Is there any way to install it?, now it's downgraded to 2.1.1 because the other IPSWs gave me the same error on iTunes... This is very annoying, seriously.

    Any help will be highly appreciated.

    Thanks in advance,
    Daniel.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    Plug it into iTunes and click the Update or Restore button. iTunes will then download the correct IPSW and update the iPod. The latest firmware version is 4.2.1.
     
  3. dreamersofeden thread starter macrumors member

    dreamersofeden

    Joined:
    May 26, 2011
    Location:
    Spain
    #3
    As I said, it downloads that IPSW but after that it gives me the stupid "This device is not eligible for the requested build." error.
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    Check your hosts file for any references to apple.com and remove them. Use Google to find out where the hosts file is and how to edit it.
     
  5. dreamersofeden thread starter macrumors member

    dreamersofeden

    Joined:
    May 26, 2011
    Location:
    Spain
    #5
    Hi, I forgot to say that I've sucess after using iREB.
     

Share This Page