Is there something wrong with my MBA? (External HDD and Time Machine Help)

Discussion in 'MacBook Air' started by Hellishness, Nov 17, 2010.

  1. Hellishness macrumors 65816

    Hellishness

    Joined:
    Jan 27, 2010
    Location:
    Bay Area, CA
    #1
    OK, This is seriously pissing me off. I have a 500GB hard drive that my MBA simply will not recognize anymore. I admit that I did turn it off without properly ejecting it one time (didn't know it would do anything), but it was not running anything off that disk and I didn't even have a Finder window open with it in it.
    It works on my PC. So now I have a hard drive that I really can't do anything with (I have important PC backups and stuff, but for my main Mac usage, it's useless). It just doesn't get recognized in any way when I plug it in, and the light turns red.


    Now I have a new problem. I tried to use Time Machine to back it up, but it just tells me that the disk was not ejected properly, and that the backup failed because the disk was removed. This is pretty damn annoying because the disk sure as hell was NOT removed. I had it sitting on my desk next to me while I sat on my bed and worked. It was plugged in securely, the USB to the HDD and the computer were definitely connected, and there's no way there could have been any physical movement. I've repaired it in Disk Utility countless times, erased it and restarted the whole process, restarted my MBA, and verified the disk many times, and every time it tells me that it's fine.

    Can anyone help? Please? I need to take it to Apple (unrelated dead pixel issue, which is the reason I tried to back it up in the first place), and now I'll definitely mention this issue.
     
  2. miata macrumors 6502

    Joined:
    Oct 22, 2010
    Location:
    Silicon Valley, Earth
    #2
    Maybe Time Machine needs a reset. If you have a second external disk try switching disks once and then go back to the problem disk. You might even be able to use a USB stick or SD card.
     

Share This Page